2

I'm having a problem: I have to run a application (SetPoint from Logitec) as administrator for it to work properly. However, it is now impossible to let the application start an app - I tried the build-in way and I tried the "Obly Tile AppLauncher" (lets you start app from the command line), however, Windows claims that the app can't be started as administrator [Edit: "Exact" error (translated): "Music" cannot be opened while Explorer is running with administrator rights, please start Explorer normally and try again]. So I searched a bit and found some approaches, however none of them seem to work:

  • Runas /trustlevel: If I try this with runas /trustlevel:2 test.bat (where test.bat runs the App launcher with the appropriate arguments), it doesn't work.
  • set __COMPAT_LAYER=RUNASINVOKER: Same as above, Windows seems to completely ignore this command if put in front of the App launcher call

Is there any way or any application that allows me to fix this? The problem is, this breaks most of the special keys on my keyboard...

Edit from SU peer :

SetPoint Logitech is a software that lets you customize settings for your mouse and keyboard.

  • use the good old Task scheduler trick: msfn.org/board/index.php?showtopic=135472 Copy the lnk file of the shortcut into the startup folder to run it at logon. – magicandre1981 Aug 10 '14 at 5:48
  • Unfortunately, this doesn't change anything - windows still says: "Music" cannot be opened while Explorer is running with administrator rights, please start Explorer normally and try again (Sorry if it's not perfect, I had to translate it) - I could confirm that it is indeed SetPoint causing the problem, but even starting it like you proposed, it still claims that Explorer is running with administrator privileges – Lukas Lang Aug 10 '14 at 7:52
  • This is by design please refer to the following url for more information:superuser.com/questions/499917/… – Supun Aug 16 '14 at 3:24
  • I realise that it's impossible to start the app so that it has elevated rights - what I'm trying to achieve is simply to start it. The problem is, every child process has the same rights as the parent process, so if I try to start an app using an application running with elevated rights, this doesn't work because, like you said, an app can't be started with these rights. Because of that, I'm searching for a way to start the app, "forgetting" about the elevated rights of it's parent process. – Lukas Lang Aug 17 '14 at 20:49
  • Do a google search to RunAdmin on Soft.Tahionic.com. Does exactly what you want. – Ultralisk Jan 27 '17 at 21:11
0

I finally found a solution to my problem: (for those who might find this in the future)

After searching for hours, I found this. It shows how you can start an application as the desktop user from an application with elevated rights. After modifying the code a little bit to take command line arguments, this solution works perfectly (as far as I can tell)

-1

i was having trouble with Setpoint as well being very glitchy with explorer (not grabbing things correctly, double clicks, etc.) The best thing that helped me was uninstalling all Setpoint drivers from the system, unplugging the unifying receiver, installing unifying software on another computer, hooking up unifying USB receiver to that computer and then double checking that there were no phantom device pairings that tend to get "stuck" in the USB receivers flash memory. I noticed this issue when

I would end up with duplicate device installations under keyboards and mice in Device Manager, as I would have an extra USB input keyboard and/or mouse.

I would then hook the receiver back up to the original computer and first run Setpoint Installer as an Admin, making sure it replaced the defunct Logitech download manager drivers, USB input configuration drivers, unifying etc etc. There are 5+ special driver installations that correlate to Setpoint in the device manager if you have keyboard and mouse. Kind of ridiculous if you ask me, but these drivers are very sensitive to any sort of misconfiguration, mislabeled driver installs.

Once I had everything aligned with the Device Manager, I then changed the swipe to close variable in the registry for Wwindows 8 Apps, as Setpoint doesn't like to be sticky when grabbing metro apps for close, but works just fine once this metric was changed. I found an program called Appuituner or something that simplified modifying the necessary registry entries for this process, but not needed.

I originally thought I had a defecting mouse it was so bad with double clicking, as I would always try to troubleshoot this problem by repairing the mouse and shutting it off, pressing all the buttons down to try to clear any static charge it may have built up, but this was never a fix for me, but may work for others.

These problems bothered me for a couple weeks, so much so that it makes me paranoid that the problems will come back that I want to reinforce Setpoint in every way possible to prevent the nightmares Setpoint has been, hence how I found this thread as I want to run Setpoint with admin privileges.

I was not able to recreate the issue you are having with executing windows apps, not sure if this is because I changed the setpoint.exe file properties with app compatibility settings for all users to run as admin, rather than the exact methods you did, or because I have played around with gpedit loosening a variety of UAC and other windows permissions.

  • I really don't see how this answers the question "Start Windows 8 App from program with elevated rights" – user 99572 is fine Aug 23 '14 at 9:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.