3

Updating the question because I know more about the cause of the issue, but still don't know how to solve it.

Currently I can see thumbnails for some CR2 files in windows explorer. Maybe only 1-5% of all of them. I can force windows to generate a thumbnail for any specific thumbnail (by repeatedly clicking it and pressing F5 to refresh its folder). Therefore, I don't think the problem is that I lack an app that can read and create CR2 thumbnails. I definitely have an app that can do this (FastPictureViewer). I have hundreds of thumbnails successfully generated. The problem is that I have tens of thousands of RAW files.

Just FYI, Canon's own Raw Codec, as well as Microsoft's Camera Codec Pack, as well as SageThumbs, are all based on an older version of the CR2 format so they don't work to make thumbnails for RAW files created by a newer camera, in my case a Rebel T5.

I am 99% convinced the problem is because Windows has a limit to the size of the thumbnail cache. A registry entry exists to increase this limit:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ Create a new key called Max Cached Icons and give it a value that represents the size of if the icon cache, i.e. 4096 for 4 megs.

Here's where it gets muddy - I have gotten much conflicting info about this key.

• Some say this key should be of the type "string"
• Some say it should be of the type "Dword"
• One user suggests it should be "Qword" on a 64 bit system.
• One user says it used to be "String" but this is considered unorthodox to control with a string value, and should be a dword, and one of microsoft's updates for windows7 changes it to the more approprite dword type.
• I've seen the key both with and without spaces (e.g. MaxCachedIcons) Without is more typical for a registry key but several users go out of their way to say "yes, include the spaces even though that's unusual".

Additionally - there is no single file for the thumbnail cache, there are multiple files for the multiple icon sizes. These live in C:\Users[Username]\AppData\Local\Microsoft\Windows\Explorer and are named

thumbcache_32.db
thumbcache_96.db
thumbcache_256.db
thumbcache_1024.db

So it's unclear if this setting limits the size of all 4 files together, or allows each of these 4 files to grow to the limit you set.

After deleting these and allowing windows to rebuild them, I either don't have the registry key in the correct format (though I experimented with many formats), or Windows has a hard limit on the thumbnail cache that can't be exceeded regardless of the size in the registry key. I tried 2048, 4096, 8192. Weirdly, the files at one point wouldn't go beyond 3148 kb (3 megs). Currently they are stuck at 4096 but the registry key is set for 8192. I have never seen any of these files grow beyond 4096.

I know I am on the right track because if I delete them and then start forcing thumbnails to generate using the method described earlier, the size of the icon database list grows (thumbcache_idx.db) but the other .db files refuse to grow any more. This link describes how the thumbnails all work: http://www.identatron.co.uk/wp-content/uploads/2012/01/Cyberforensics-2011.pdf

And these files definitely control the CR2 thumbnails because I can use a small app called thumbcacheviewer (or thumbcache_viewer) to open the DB files and view the thumbnails inside of them, and they are my CR2 thumbnails.

So right now, I am convinced I have hit the limit of thumbnails in windows. Now it's just a matter of... if I enter this registry key in a different way, can I bypass the limit? Or is it just set in stone?

  • Did you try clearing the thumbnail cache? Do you get the same issue if you use a different account? – and31415 Aug 10 '14 at 15:46
  • @and31415 yes cleared thumbnail cache, yes same issue in another account. Also tried booting in safe mode and same issue. – CreeDorofl Aug 10 '14 at 17:44
  • Are there any files in the C:\Windows\Minidump folder? Dump files could shed more light on the BSOD. If you haven't already, check the file system health by running this command from an elevated command prompt: chkdsk %systemdrive% /r When done, check the system integrity by running the following command: sfc /scannow – and31415 Aug 10 '14 at 18:32
  • @and31415 hi, thanks for the suggestions. No minidump folder. SFC found a corrupted file and fixed it. I then ran chkdsk and no errors found. I did find a bunch of errors under event viewer around the time it probably happened. They haven't returned since then. I copied just these errors to a text file but it came out with xml, kind of a pain to read? dropbox.com/s/fzbdrj83nsrjygz/creedorofl_error_log.txt – CreeDorofl Aug 12 '14 at 0:57
  • Run the sfc command again and ensure there are no issues. Where are your .cr2 files stored, exactly? Do you get the same issue if you copy them to an external drive/media? Also, is the C:\Windows\LiveKernelReports folder empty? I checked those errors, but I guess they're unrelated as they refer to network services. – and31415 Aug 14 '14 at 14:24
1

According to the error log that you posted, the problem dates from august 10, which is recent enough to rollback Windows to a system restore point that dates to before that time. Ensure first that all the software you had at that time is installed in the same folders as before. This will also create a new system restore point from now, that you can rollback to in case you wish to undo the first rollback. I would also take before starting a disk image backup of the system drive just in case.

If this doesn't work, I suggest uninstalling the Camera Codec Pack and FastPictureViewer using Revo Uninstaller Freeware. Then reboot and install instead the free SageThumbs. If it doesn't work, uninstall it from the Control Panel Programs and Features.

If nothing works, I suggest buying the FastPictureViewer Codec Pack ($9.99) and asking for support if the problem still occurs.


In case you have run into the icon disk size limit :

Icons are cached in the iconcache.db file whose size is limited by default to more or less 500KB.
Here is how to increase this limit :

  1. Run regedit and navigate to the key
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer
  2. If you do not see on the right pane an entry named Max Cached Icons, right-click on an empty area, then click on New and on String Value, type Max Cached Icons and press Enter.
  3. Double-click on Max Cached Icons to modify it.
  4. Click on Decimal
  5. Type a number for how many kilobytes (KB) you want the maximum icon cache size, for example 8192 for 8 MB.
  6. Click on OK

For more detail see the article Windows 7: Icon Cache Size - Change in Windows.

You might also need to rebuild the Icon Cache and reboot for this to take effect.

  • Hi, thanks for the suggestions. So far I tried a system restore which happens to offer only as far back as the morning of August 10th. I clicked "show more restore points" but got nothing. I ran the earliest restore point available and after the reboot I get "System Restore did not complete successfully" etc. It references failing to replace the file "C:\Windows" which is a lil vague. I tried a different restore point with the same result. I tried Revo Uninstalled, killed all traces of FastPictureViewer, but admit I forgot about CCP. In any case all thumbs for CR2s disappeared. – CreeDorofl Aug 14 '14 at 13:05
  • Afterwards, I installed Sagethumbs. It slightly changed the CR2 icon but failed to replace it with a thumbnail. It labels the CR2 file as an "EOS 1D Mark II" raw file which unfortunately is a camera from like 2006. So I don't think it's up to date on canon raws. Any other thoughts? Uninstall CCP just to be safe or does that seem like a dead end? – CreeDorofl Aug 14 '14 at 13:07
  • I suggest uninstalling every related product except the software you are testing. Analysis: Evidently something changed on your computer. The likely assumption is that this was done by Windows Update, and then a possible conclusion is that perhaps the old FastPictureViewer is no longer compatible with Explorer. (I wonder if the problem is only with .rc2 files?) A newer version could possibly fix it. At least as a client of the latest version you could ask for support. But it's your $9.99; and my analysis might be in error. – harrymc Aug 14 '14 at 14:16
  • I think fastpicture viewer is working fine because many CR2 thumbnails do show up. It's just that we're talking only 1% or 2% of all the CR2 files on my system. I'm wondering if it's this windows thumbnail limit I've read about while googling. One user claims windows stops caching thumbnails after about 7,500 of them. – CreeDorofl Aug 15 '14 at 15:14
  • It's possible if you have very many image files. I have added above how to increase that limit. – harrymc Aug 15 '14 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.