1

I playing a video file with a .srt subtitle file using VLC on OSX 10.8.5. The subtitles are displayed, however the location changes randomly every few sentences from low (the regular sub position) to a bit higher to almost halfway up the screen.

Below are a few screenshots showing the low, middle and high positions respectively. The screenshots are just seconds apart.

Low position
Medium position
High position

How can I make the subtitles stay in one position, i.e. the low position? Using the Force subtitle position parameter changes the position of all the subtitles, regardless of their actual placement.

This is the subtitle file I'm using.. I've tried another subtitle file from here, but the problem persisted.

Is there some location information embedded in .srt files? Can I remove that? Is there another way of solving this problem?

2

I have checked the subtitles, and I see there are wrong timestamps in them:

For example, line 4 is displayed until 0:00:46.84, whether line 5 start time is 0:00:46.83.

That means that VLC showed first subtitle in place (bottom line), but when it needed to display the next line, the bottom was still in use, so it should display in a "free" space (just above), but only 0.01 seconds later, it hides the bottom line, thus making it appear as if it were working incorrectly.

You may retouch the subtitles yourself in order to correct the timestamps, but I could not find an automated way to do so. There are plenty of overlapping errors, (like 1 every 4-5 lines or so).


To correct the times I used aegisub. Once loaded the subtitle in the program:

  1. Under Automation -> Select overlaps, it would select all the lines that overlap with the previous line.
  2. Then, under Timing -> Shift times, choosing a Time of 0:00:00.01, only selected rows and start times only and apply.
  3. GOTO 1, repeat until no rows are selected.
  4. Export as .srt (to keep original format)
| improve this answer | |
  • Thanks for pointing that out! I've looked at the .srt file myself in TextEdit but didn't notice this. Going through the file manually is not feasible, so if anyone finds an automated solution/script that would be great. – Saaru Lindestøkke Aug 10 '14 at 22:28
  • 1
    OK, I found a way around to correct them, here you have it: http://pastebin.com/e2E0D2F1 – NuTTyX Aug 10 '14 at 22:36
  • Wow, awesome! How did you do that? Could you maybe include the method in your answer such that future users can apply it to their subtitle file? – Saaru Lindestøkke Aug 10 '14 at 22:52
  • Added method to answer. – NuTTyX Aug 10 '14 at 23:06
1

I have Subtitle Edit 3.5.7. (Free download, just noticed later version available). It has an option Tools -> Fix Common Errors... "Fix overlapping display times" is one of the many fixes available. It worked fine for me. I note that it works by shifting the start times, rather than the end times as in the fix above. Since my overlaps were small I couldn't see a difference.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.