2

I recently bought a TP-Link Archer C2 router, and I am very satisfied with it so far. I have only a single problem: Bonjour service advertising seems to be broken.

My network:

  • Simultaneous 2.4 and 5 GHz networks
  • 2 Macs, 1 Ubuntu and 1 Windows 7 computer
  • 3 iPhones, 2 Android phones
  • HP printer
  • Kindles, etc.

What I tested:

  • The Macs do not see each other in Finder
  • My Mac does not see the network printer (used to work)
  • My Mac does not see the iPhone, when I start some app which provides WebDAV access and announces it with Bonjour
  • Bonjour Browser shows only my local computers advertisements
  • The iPhones do not see the AirPrint service of the printer
  • I've tested using only a single WiFi band instead of both of them, did not help
  • The router provides IP addresses from the same IP domain to all of the networks (192.168.0.1/255.255.255.0)

Where could the problem lie? What do I need to check to fix this? Is it maybe some multicast package forwarding issue? If so, where can I fix it?

  • This is a potential answer: superuser.com/questions/730288/… :( – hooby3dfx Oct 30 '14 at 22:13
  • I don't think this is the issue for me. I had an older, 802.11n only TP-Link router, which worked perfectly with the same setup. The only reason I replaced it was the ac speed. – gklka Oct 31 '14 at 0:03
2

Do you have any active devices between your Mac and the router? Bonjour packets have a TTL of 1.
Does running dns-sd -B on your Mac list your other devices? Does dns-sd -F show local as a browsing domain?
Try pinging: ping 224.0.0.251 or ping6 ff02::fb

On the router, try enabling Network > WAN > Advanced > Enable IGMP Proxy and IPv6 WAN > Advanced > Enable MLD Proxy – it shouldn't affect multicast packets on the LAN, but you never know. :)
Try setting Wireless 2.4GHz > Wireless Advanced > DTIM Interval to 1.
Try disabling anything firewall-related (Security > Basic Security > Firewall > Enable SPI Firewall and all the options under Security > Advanced Security), and if this solves the problem, re-enable them one by one.

  • It seemed to solve the issue for a while, but after some days the same happened. Sometimes bonjour sharings are working, sometime not. :( – gklka Sep 23 '14 at 6:51
2

I've contacted TP-Link's user support. In the result of this, they have improved the Bonjour support of the router in the 11/17/2014 software update:

http://www.tp-link.us/support/download/?model=Archer+C2&version=V1#tbl_j

So far (since 2 days) it seems working fine, so if you have similar problem, you only have to update your router.

0

I have had a similar issue with the TP-Link Archer C50. Bonjour devices would just not show up. I had originally set up the router as an access point, basically extending an existing LAN with additional WiFi.

What solved the problem for me was configuring the router as a router, that is, selecting this option:

Before enabling it, you will have to plug in something into the WAN port. Then, after enabling it, unplug the cable, wait for the router to restart. Now connect your PC again, navigate to 192.168.0.1 (the router's default address), and change the Network » LAN address of the router to something other than your existing router's IP. Restart, then go to DHCP and disable the built-in server. Restart once more and the router should work.

protected by Community Apr 9 '15 at 11:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.