0

i try to configure openoffice in linux server to use comma as decimal separator,i search and i found that have a relation with regional parametre so i configure etc/locales.conf to use french as default language but i still have the same problem (the file i use is an xlsx 6 300,20£ is transformed on 6,300.20£):

[default]
date format = %b %e %Y %I:%M:%S:%z%p
        LANG=fr_FR.UTF-8
        LC_CTYPE="fr_FR.UTF-8"
        LC_NUMERIC="fr_FR.UTF-8"
        LC_TIME="fr_FR.UTF-8"
        LC_COLLATE="fr_FR.UTF-8"
        LC_MONETARY="fr_FR.UTF-8"
        LC_MESSAGES="fr_FR.UTF-8"
        LC_PAPER="fr_FR.UTF-8"
        LC_NAME="fr_FR.UTF-8"
        LC_ADDRESS="fr_FR.UTF-8"
        LC_TELEPHONE="fr_FR.UTF-8"
        LC_MEASUREMENT="fr_FR.UTF-8"
        LC_IDENTIFICATION="fr_FR.UTF-8"
        LC_ALL=fr_FR.UTF-8


        [fr_FR]
date format = %b %e %Y %I:%M:%S:%z%p
language = fr_french
charset = UTF-8

is there an other solution to fix this problem

2
  • I assume you also need to adjust the OpenOffice user profile settings. Did you try this already?
    – tohuwawohu
    Aug 12 '14 at 9:19
  • no i didn't adjust the OpenOffice user profile settings,how can i do it because i'm in linux server ans i can acces just with putty
    – JV_MISR
    Aug 12 '14 at 9:21
0

If OpenOffice.org isn't reading your /etc/locales.conf as you want it to, you could also try changing the locale on the command line before running OOO. Like this:

export LANG=fr_FR.UTF-8; soffice -calc;
2
  • the command doesn't work [root@root ~]# export LANG=fr_FR.UTF-8; soffice -calc; -bash: [root@root : commande introuvable
    – JV_MISR
    Aug 12 '14 at 9:55
  • How do you usually start openoffice? Just add export LANG=fr_FR.UTF-8; before that. I thought that soffice -calc would start up OpenOffice Calc. Aug 12 '14 at 14:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.