0

For those of you into Python you probably know about IDLE. I use it so often that I have it pinned to my taskbar, but I've got a metro/Modern UI theme going so I want to change the icon of it. The problem is that because IDLE is a python file, you can't change the icon like I normally do using this method, because it's a file rather than an application. So when you go to pin it, it just pins the normal python file icon with IDLE pinned as a file! I then tried changing the default icon associated with .py files and found that it didn't work; the default python icon still stayed there (see below image)! What I'm trying to do is change the icon to a different one; is there a way to do this other than the methods I've already tried?

Default Python pinned icon The default python icon

Attempting to pin  IDLE result in this Attempting to pin IDLE results in this

problematic new icon appearing

  • 1
    You can also compile python script to .exe or make launcher .exe on other language who will pass command line to python. – crazypotato Aug 12 '14 at 10:17
  • @crazypotato I should have thought of that! Thanks for the suggestion. I'll let you know if it doesn't work – Often Right Aug 12 '14 at 23:53
  • 1
    Does anything at maxi-pedia.com/change+icon+greyed+out help? – Jason C Aug 13 '14 at 4:53
1
  1. Create a shortcut on the desktop (right click on desktop->new->shortcut) then enter "cmd" in the place of type the location of the item.
  2. Change icon and name on "cmd" shortcut for what you need.(DONT change path)
  3. Drag this shortcut to the taskbar so its will be pinned.
  4. Press Win+R, paste and run this: %APPDATA%\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar
  5. Find what you pinned in the open directory and change path in "cmd" shortcut for what you need.

Path alone for easy copy:

%APPDATA%\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar

IDLE path so you can set it in shortcut


Another way:

I will show how make launcher .exe with custom icon on Autoit.

After install Autoit and Editor. Right click on desktop->New->Autoit Script. Right click on this created file->Edit. Now you should see ScITE window after line "Add your code below here" add this code:

$executable="C:\App\pythonw.exe"
$parameter="C:\App\IDLE.py"
$workingdir="C:\App\"
run('"'&$executable&'" "'&$parameter&'"',$workingdir)
  • change path $executable in quotes for pythonw.exe
  • change path $parameter in quotes for IDLE script
  • change path $workingdir in quotes for working directory pythonw.exe(in most cases same directory where locate pythonw.exe)

in the ScITE window press Tools->Compile->Change icon->Compile script. In same directory where autoit script was created now .exe with custom icon who can run for example IDLE.

But i dont think this solve problem with appearing icon on taskbar with metro theme.

  • Thanks for that, but the 'change icon' option is greyed out when I do that! Still, I appreciate the effort! – Often Right Aug 12 '14 at 23:49
  • Almost everything what i answer i test before post. So how possible "Change icon" greyed option on newly created "cmd" shortcut on desktop? Show screenshot. Probably my english too bad so you cant understand. – crazypotato Aug 13 '14 at 4:45
  • I don't know I'm afraid. You suggest a method very similar to what I originally did (although I didn't do steps 4 and 5 originally, but when I did it, it still didn't work - see edit). I just don't know how it can be changed without making it an application! – Often Right Aug 13 '14 at 4:47
  • 1
    You dont follow my instructions:( You should create shortcut "cmd" not python thing. The only thing you can change its when i write for what you need. – crazypotato Aug 13 '14 at 4:51
  • Ah, I see I misread it. Thanks for that. I was making the shortcut to the desktop then changing the path instead of changing the path later on! My apologies. It works well, the only thing is that it opens a new icon on the taskbar (i.e. next to the pinned IDLE shortcut there is another icon). Any suggestions for that? – Often Right Aug 13 '14 at 5:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.