0

I am using Windows 8.1 [Update 1] and have recently had some issues with the Mail, Calendar, and People set of Modern UI apps. Out of nowhere, all of my Modern apps stopped working correctly, displaying an 'X' in the bottom-right corner of the tiles and saying "This app can't open. Check the Windows Store for more info about .

However, this is not the case.

Although I can reinstall most of the other apps and they open just fine, I have had some trouble with Mail, Calendar, and People. When I uninstalled the three applications and reinstall them from the Windows Store, they seemed to download and install 'instantaneously' [if my memory doesn't fail me]. Then, when I go to open any of them, it gives me the same error message, sans bottom-right X. When right-clicked, there is no 'Uninstall' selection for any of them.

I am using an Acer Aspire M5-533P-6428 touchbook. It has 8Gb RAM, an Intel i5-4200u quad-core processor, and a 500GB internal hard drive.

If there's any solution, please let me know ASAP. I need the Calendar for school and Mail for, obviously, managing e-mail.

[EDIT] When I attempt to open any of the three apps, it does not display a splash screen and simply gives me the error message at the Start Screen. Before the attempted reinstall, it would open to the app's splash screen and displays the error message.

1

Try refreshing your PC. In Windows 8(.1) you can restore your computer to factory, without affecting any of your files.

http://windows.microsoft.com/en-ca/windows-8/restore-refresh-reset-pc

Follow this link and follow the instructions for "Refresh your PC without affecting your files." You can also try "Restore your PC to an earlier point in time" if you have a restore point available that's not too far back.

Before you do anything, it's probably not a bad idea to back up all your files, or create a system image. Just in case.

Best of luck!

  • So, finally getting back to this. I ended up doing a bit more research and finally refreshing my PC. Everything is working fine now. – EnragedTanker Nov 18 '14 at 17:37
1

check this method

http://www.tomshardware.com/answers/id-1928119/windows-apps-working.html

it worked for me

and i hate when people tell you to refresh what the point of doing that if i want to refresh i will not ask how that can be fixed

Best Regards,

  • 2
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – Tetsujin Dec 31 '14 at 20:28
0

Okay, I figured it out. Not saying that this will work for everyone, but it did for me.

What I did was this. I opened up the Windows Store and navigated to Account > My Apps. From there, I had it set to show all apps that are not installed on my PC. In that menu, I noticed that it said Mail, Calendar, and People was not installed. So I clicked that and found that the store allowed me to install it. So I did that, and now everything works fine!

Now I need to figure out what's making OneNote crash on startup. :/

EDIT: This was a temporary solution, and it didn't fix everything. After some contemplation, I ended up refreshing my PC.

0

Hye guys finally i found the stupid answer for this stupid problem! god damn it. I have been looking around for 3 days now! so the problem is really with the permissions so all what u have to do is the following :

  1. go to C:\Program Files in this case my system is on C and make sure that you had already went to view >options and enabled hidden items + untick "Hide protected operating system files".

  2. Then try to find a hidden folder called " WindowsApps" inside of Program Files folder .

  3. right click and "properties" > then untick "Read-only" and if you can't do that then u need to take control of the folder in the following step and then do it again.

  4. "properties" again but in this time go for "Security" from the top

"Advanced " , then look for the "owner " and u will see a username next to it most of the times "System" > click change

"Advanced" again from the next window > press "Find Now" and locate your username and choose it "ok" > "ok" again.

Now u will see in the "Permission entries" a list of users , make sure that "All Application packages"+ "TruestedInstaller " +"Creator owner" have full access ! if they are not u must give them full access.

  1. make sure to tick "Replace owner " and "Replace all child" before clicking apply then ok.

    • Note:it will take u time to finish the changing owner process so be patient. After doing everything just jump and give it a shot and see!
    • again doesn't matter the order or what step you do the must important outcome is to give these three stupid usernames "All Application packages"+ "TruestedInstaller " +"Creator owner" Full Access ! for that folder. Hope it worked !
0

I had the problem where all of a sudden I would click on my email or calender app and get a splash screen for a second and that was all. I am using Windows 8.1. I right clicked on the app on my start screen and then clicked on "turn live tile off". I then clicked on "turn live tile on". It worked beautifully, restoring my email and calender back to where it had been. I hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.