Recently I upgraded to Ubuntu 9.04 on my laptop. In that it detects my wireless network but won't connect, it just keeps reprompting me to enter the WEP key! Even if I give correct password it's not connecting. Is there a solution?

  • 1
    this irritated me so bad I installed Windows 7 RC back onto my Laptop Jul 24, 2009 at 4:25
  • More information would be useful. Could you add the contents of: $ iwconfig And also say what type of wireless device you have. Try $ lspci $ lsusb and look for wireless to see what it is. Aug 4, 2009 at 17:28

8 Answers 8


It almost sounds like you may have a config file set up to connect for you, which causes network manager/wicd and others like it not to work. I wish I could remember the name of the file you need to check, but hopefully that gives you some more info on what to search for to fix the problem.

  • If you are using Ubuntu/Debian, you are probably thinking of something in /etc/network - the interfaces file is the standard one. Aug 4, 2009 at 17:25

Try clean installing Ubuntu 9.04.

There were many improvements made to the Wi-Fi infrastructure in version 9 from version 8. I had a similar problem, and the clean install enabled all the wireless networking to work.

  • Before formatting over, the OP might want to boot from a live CD and check whether it's working with that one.
    – innaM
    Aug 1, 2009 at 20:16
  • A couple of days ago I did a clean install of 9.10 and got exactly the same problem as the OP - a list of wireless networks, which challenge me for the correct type of authentication, but then keep repeatedly asking for it again instead of connecting. Mar 21, 2010 at 8:59

What software do you use? Try wicd:

$ sudo apt-get install wicd
  • I have difficulties with ubuntu and wireless networks as well*. Can I download wicd as a .deb package ? I can't download it view apt-get, obviously. *I asked a question about it.
    – Manu
    Jul 29, 2009 at 18:54

Thanks for the pointer to wicd, it's indeed more to my taste. I have a similar problem as the OP, but even installing wicd doesn't solve it (for me). In fact the connection attempt appears to always time out. I'm using the Ubuntu 9.04 netbook remix.

I've also tried the alternative madwifi driver which gives exactly the same result (i.e. none).

My guess is that some driver has changed in a way that makes the WLAN card unhappy or so. The weird part is, though, that even the alternative driver doesn't change anything. Booting into Windows XP SP3 works perfectly fine and offers all the wireless connectivity that's expected.

lspci says the card is:

Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev1)


You could see if there are any restricted drivers that could be enabled - these are drivers provided by the wireless card chipset manufacturer but not under a FOSS license. To look for these, go to the System Menu -> Administration -> Hardware Drivers


When I upgraded to Kubuntu 9.04 I had the same problem. I had to uninstall the Plasma Manager for Wireless, Install wicd And configure wicd to manage my Wireless Network - no problems since then.


Your system version is VERY old.....I'd suggest upgrading to AT LEAST 12.04.x LTS so that you get the newer driver set and improvements. The Ubuntu at your level might not have the appropriate drivers, and of course lacking the later security modifications to make your system safer.


I had the same problem when I updated from Debian Squeeze to Wheezy - I use an Atheros AR5416 card that worked fine before upgrade and wouldn't connect at all after the upgrade. It would just keep prompting me for the passphrase. I'm using a plain-vanilla NetworkManager configuration, without any specifications for wlan0 in /etc/network/interfaces.

The fix was to add the following stanza to /etc/wpa_supplicant/wpa_supplicant.conf:

network={ ssid="your-ssid" key_mgmt=WPA-PSK auth_alg=OPEN psk="your-passphrase" priority=1 }

I restarted the machine and it worked.

You must log in to answer this question.