2

So, I just gave up trying to get my screen brightness keys working properly and now I'm searching for a way to decrease the brightness of my screen artificially.

Maybe there's a gnome shell extension for that. For example, when I hit the turn off botton. Everything becomes darker except for the box that says "turn off", "suspend", etc. May be there's an extension for making things darker that way?

Any help would be appreciated.

2

Under /sys/class/backlight/, there should be several folders with your kernel's supported backlight devices.

<device>/max_brightness keeps max device brightness setting.

WARNING: Don't change brightness to 0. This might turn your screen backlight off untill you restart your computer or undo the settings. Also don't change to a value above max_brightness.

With echo <sane value LESS THAT max_brightness> | sudo tee /sys/class/backlight/<device>/brightness, you should be able to play with your backlight values.

  • I see nothing under /sys/class/backlight/. – Hugo Aug 14 '14 at 2:53
  • This works on gnome shell under debian stretch. I can reduce screen brightness (my eyes couldn't stand it anymore) but the panel slider still not working. Thank you – Eduardo Jul 12 '17 at 19:44
0

go to the terminal and type these commands:

sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf

and

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

now you will need to copy and paste this into the file

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"

EndSection

save the file. then reboot your laptop, and it should work. tell me if it works for you. my laptops brightness stopped working, i used this and it fixed my problem. if it doesn't work then please tell me. =)

  • Thanks for your answer, however that didn't work. Right after I rebooted, it showed the fedora "f" logo, then displayed some command prompt lines and freezed. – Hugo Aug 18 '14 at 5:40
-1

This works good!

sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf.

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf.

Section "Device" Identifier "card0" Driver "intel" Option "Backlight" "intel_backlight" BusID "PCI:0:2:0" EndSection

and this works too! echo 1800 >> /sys/class/backlight/intel_backlight/brightness

depends on ur primary display adapter

  • 1
    Welcome to Super User! This duplicates another answer and adds no new content. Please don't post an answer unless you actually have something new to contribute. – DavidPostill Jun 28 '15 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.