0

The title is rather self explanatory, but here some more details. I'm currently running my machine with Windows XP x64 (read Windows Server 2003) and I was planning to install CentOS 7 on the same drive to create a dual OS layout.

Now, the procedure I always followed is pretty standard: boot from the installation DVD, configure the partition layout directly from there when asked, install and reboot the system, at which point I was asked by the bootloader which OS I wanted to use.

I'm quite familiar with the OpenSuSE installation, and I've always been able to see NTFS partitions (of any Windows version, up to Windows 7) and manage them directly. I read on this site an answer explaining that there could be troubles with the "new" disk management of Microsoft's, but here we have a plain old MBR partition index, so there should be no problem.

This time, though, both installers are unable to see the NTFS partitions -thus being unable to manage them. I wouldn't mind having to resize them directly from Windows: I'm equipped to do so. What troubles me is the inability of the installers to detect them.

I shall add at this point some details about the system: it's a RAID0 stripe of five devices, the controller is an Intel ESB2 from a 5400 "Seaburg" chipset -so, not really the newest hardware out there.

Any idea to solve this issue? Thank you very much.


Update: I tried shrinking the NTFS partition from Windows: now the disk has 500GB free and I tried Fedora 20. Both CentOS and Fedora AT FIRST read the 500GB free and an unknown partition. As soon as I try to set up the Linux partitions, this faint awareness of the neighbourhood vanishes and the disk "becomes" free. I could just try to let Anaconda do its course without trying to have a word in the partitioning process -the Windows installation is new and can be easily rebuilt from scratch. But it's quite annoying nevertheless.

Ideas?

0

I think CentOS show your windows partition as a unrecognized device. most probably the CentOS guys are not loading the NTFS module. But as you are writing as "unable to see NTFS partitions" can you please post a screenshot.

You can post a bug in Bugzilla if you think it's a bug.

  • Thanks for the answer. It tells me the drive is empty: no partition, no nothing on it. I don't think it's a bug, otherwise switching to a different distro should solve the problem, but it's not so. – Lorenzo Zanetti Aug 13 '14 at 11:58
  • Hi, is your HDD drive getting detected? – Rituraj Aug 13 '14 at 12:03
  • Yes. SuSE is able to see the individual HDDs in the RAID0 stripe as well -CentOS doesn't bother with that, I guess. I'll soon try to shrink the NTFS partition from Windows and see if that helps, somehow. – Lorenzo Zanetti Aug 13 '14 at 16:33
0

Solved: OpenSuSE 13.1

Here is the problem: if you use a RAID hard drive, SuSE might ask you if you want its MD Partitionable RAID subsystem to manage the partitions. If you say YES, this subsystem will handle your disk as if it were empty by default. So, to avoid problems, just click NO when asked.

As for Fedora and CentOS, their Anaconda installer didn't manage anything good. CentOS' even crashed once.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.