20

I have a laptop with Intel GPU and their software is currently faulty in that it globally registers certain keyboard hotkeys and won't let them go. The way to kill them is to kill the igfxHK Module:

enter image description here

The problem is that this "module" which is represented with the C:\Windows\system32\igfxHK.exe file is started after each reboot.

I have tried using Autoruns to disable it but when I do a search for "igfxHK" there, it yields no results. What are some other ways I can try to disable this EXE from starting up with Windows?

2
  • What driver version are you currently using? The startup entry for that specific process should be located in the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run registry key.
    – and31415
    Aug 13, 2014 at 16:17
  • I have the same problem in Windows 7
    – geneorama
    Nov 15, 2014 at 20:57

3 Answers 3

14

I found igfxCUIService1.0.0.0 in autoruns, where CUI is common user interface. On a hunch, I disabled that. Hotkeys are now fine on reboot. So far I haven't noticed any negative consequences.

0
14

I had this issue on Windows 7. I was finally able to turn it off by setting the service Intel(R) HD Graphics Control Panel Service to Manual and restarting.

8

Right-click on desktop and select Graphics Properties. This should open up the Intel Control Panel, select Advanced if the option is offered.

In the Options and Support tab, at the top, is a check-box for enabling/disabling hot key functionality. Try that.

3
  • That should work but because of this bug: communities.intel.com/message/237171 one has to manually kill the process. Anyway, the question is more about how to generically prevent such processes from starting when you can't find them in Autoruns. Aug 13, 2014 at 12:25
  • Yeah, this is Win8 specific. I hadn't realised before you posted that comment. Turns out my Win7 doesn't even have that executable, and the hotkeys release as they should. Here's hoping Intel pull their socks up! Aug 13, 2014 at 13:07
  • 1
    They've fixed the bug in the latest version, so this solution works very well and avoids nasty hacks that completely disable the control panel. It's now under Graphics Properties... > Options and Support. Click Disable and then Apply.
    – Zenexer
    May 31, 2016 at 7:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.