1

I'm using WampServer on Windows 7 and while it works locally (using localhost), for some reason access to it from other devices using my PC's local IP, which is fixed (192.168.1.130) is not working anymore. It used to work, but I don't remember changing any configuration. I did change my router for a new one, so maybe the router is somehow preventing Apache from working properly between machines in the network, but I don't know what to change in its configuration. It's a ZTE ZXHN H218N router.

I'm not interested in connecting to the Apache server from outside my LAN, only from inside, from machines other than the server PC.

I've PINGed the server PC from a tablet (from Android Terminal Emulator) connected by WiFi to the same router, and I do get a response, but then, I can't access the Apache server from the browser using 192.168.1.130:81

In my httpd.conf file I have: Listen 81 Listen 88 Listen 89

Note there is no IP in any of the Listen statements, just the ports, so any machines in my LAN should be able to access it.

Using localhost:81, localhost:88 and localhost:89 from my server PC works (I get all three websites), so Apache is properly configured. The problem is I can't access those test sites from other devices in my LAN using 192.168.1.130:81, 192.168.1.130:88 and 192.168.1.130:89

Any ideas on how to access my Apache server from other devices in the LAN?

4
  • You said you got a new router. Are you sure your IP address has not changed? Perhaps you were doing Static DHCP in your old router, but not any more?
    – heavyd
    Aug 13 '14 at 14:46
  • My new router has the same default gateway as the old one (192.168.1.1). Both routers work with automatic DHCP, but my PC has its IP manually set in Windows (192.168.1.130). Internet browsing and even SMB folder sharing work fine in all computers. It's only Apache/WampServer the one which has issues. It used to work with my old router, though.
    – OMA
    Aug 13 '14 at 14:50
  • Can you access Wamp from your PC using that IP?
    – heavyd
    Aug 13 '14 at 14:52
  • Yes, I can use 192.168.1.130:81 and it works in the server PC, but not any other device in the LAN
    – OMA
    Aug 13 '14 at 14:53
-2

I had the same problem. Yesterday I could connect fine, then today suddenly I couldn't.

Then I turned off µTorrent and that solved the problem.

1
  • This is not an answer to the original question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post.
    – DavidPostill
    Oct 9 '14 at 7:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.