0

I am using fetchmail to retrieve emails off server and then viewing with mutt. My settings look like,

poll server.com protocol IMAP
user "myuser@server.com"
password "secret"
keep
mda "/usr/bin/procmail -d %T"
ssl

Everytime I run fetchmail it downloads all emails again, not just new ones that I haven't downloaded yet. How do I make this happen? Is this something I need to do in procmailrc?

0

Well, you are specifying keep. Check the ~/.fetchids file to make sure that fetchmail is updating it after every run, and see if you can check on the server whether the processed messages are marked "Seen".

  • Hi, the answer for me was to specify nofetchall in fetchmailrc. It is strange because I thought this was the default setting. – LJS Aug 13 '14 at 21:50
  • @user2756653 please make that into an answer and mark it correct. I also think it's strange, so it will be useful to others. – aecolley Aug 15 '14 at 0:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.