I am running linux (Gentoo 3.15.5-hardened-r2) as a guest under VMware workstation 9.0.2, the host is Windows 7 Enterprise. My desktop environment in the linux guest ist KDE 4.12.5. I use the open-vm-tools 2013.09.16.1328054-r3 (VMware tools are simply too much trouble and pain to build).

The Problem

I can copy stuff (files and clipboard contents) from other VMs and the host into the linux guest, even using drag & drop, but the other way fails. I can copy text and images from the clip board if I press Shift+Ctrl to release mouse and keyboard from the guest. But copying files or drag & drop doesn't work at all. Moreover, when I try to leave the guest window with the mouse, the mouse appears to "stick" at the edge of the guest (the mouse pointer is "flung" back into the guest window a couple of times until I can proceed, the exact behavior varies).

This all used to work once without any trouble (older version of VMware workstation, VMware tools, linux kernel, KDE, Qt, etc.).

VMware guest isolation settings are enabled for drag & drop and for copy & paste. Rebooting and restarting everything does not improve anything. vmtoolsd is running.

Any suggestions?

N.B. Updating VMware workstation is not an option.

  • Try to reinstall VMware tools. Sometimes it helps, but in my experience the problem always returns. You could open a ticket with VMware Support, but this very old problem exists on many configurations since long time and was never solved.
    – harrymc
    Aug 25, 2014 at 8:55
  • As I said, I'm using open-vm-tools (freshly updated); VMware tools are just a PITA. At least for Gentoo they simply suck. Aug 25, 2014 at 8:57
  • VMware tools were always a PITA, but might work better than open-vm-tools in your case. As I said, impossible to predict which configuration and VM will have that problem. I think it's better to avoid suspending the VM, because VMware tools in my case don't fully work on power up. Funny that you can't find a pre-built version.
    – harrymc
    Aug 25, 2014 at 9:58
  • Well, the prebuilt tools themselves do work - kind of. I have the same problem as described in the Q with them and did some VMware-Kung-Fu just to achieve nothing at all. But the VMware kernel drivers (e.g. for vmhgfs) simply don't build. This is why I dumped VMware tools. Aug 25, 2014 at 10:41
  • My last trick that I can contribute is in Guest isolation to disable drag & drop, click OK, then re-enable and again OK. Sometimes this makes it work until next time (using VMware tools). Sometimes also reinstalling VMware tools again makes it work for at least the current session.
    – harrymc
    Aug 25, 2014 at 11:08

2 Answers 2


Try the below steps,

  • Go into VM / Settings / Options / Guest Isolation
  • UNCHECK both checkboxes (Enable drag and drop, Enable copy and paste) and click OK
  • Shut down the guest, and shut down VMware Workstation
  • Reboot the host computer
  • Run VMware Workstation but do not launch the guest yet
  • Go into VM / Settings / Options / Guest Isolation for the guest, and CHECK both checkboxes
  • Power On the guest

The above steps have proved to be successful for other facing the same issue. This is actually copy/pasted from here

Note: This issue appears more to be an issue rather than anything related to config, and you already have the configs right.

  • I just tried that out, as well as other suggestions from the VMware community forum. No effect :-( Aug 26, 2014 at 9:21
  • Have you also tried reinstalling VMWare Tools or Open-vm-tools? I'm guessing you would have, but just wanted to confirm. Aug 26, 2014 at 13:41
  • Ok, I'll try that, but I believe that there's something deeper here... Aug 26, 2014 at 13:59
  • Reinstalling open-vm-tools had no (visible) effect. Aug 28, 2014 at 15:53
  • Did u ever save a snapshot of the guest OS before? Aug 28, 2014 at 16:05

I had this problem for years. I think i just solved it.

I run RoyalTS for my RDP connections. When RoyalTS is running, i cannot copy+paste between host and guest. If i close RoyalTS it starts working. Starting RoyalTS again breaks copy+paste.

I'm so happy! i can copy+paste again!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .