I have a problem that seems odd to me. I have a small patch panel in my home which is wired to various outlets. Until recently, I was running my router (an Asus RT-N66U) near the panel but am now moving it so I got a switch (Cisco SG100D-08). On the other end of this particular port on the patch panel is a Linux box running a Realtek RTL8111/8168/8411 (Not sure which, that's just the lspci output)

So here is the problem: This works: Router - patch cable - patch panel - cat6 - cat5e socket - patch cable - linux This doesn't: Switch - patch cable - patch panel - cat6 - cat5e socket - patch cable - linux

However, this DOES work: Switch - patch cable - cat5e patch panel - cat6 - cat5e socket - patch cable - Laptop (Dell Inspiron)

All patch cables are pre-made and newish. I tried switching out patch cables, all patch cables work with the switch and the laptop but none of them work with the switch and the linux box.

The switch and the linux box are compatible as it links if plugged in directly.

If there was a problem with my wiring, surely it would not work with the router to my linux box, or with the switch to my laptop, but they link fine. I only get a problem when using a combination of the switch, my cat6 cabling and the Linux box. I did try cold booting the linux box to no avail.

Now obviously, I will be going over the patch panel wiring, but until then, I am confused on a theory level - is there something in ethernet cabling that could affect only certain combinations of devices?

  • 2
    Make sure to check which of your devices are autosensing, which cables are wired straight and which are crossed. It may be the case that you need to replace cables because one of the devices isn't autosensing.
    – Teun Vink
    Aug 11, 2014 at 22:00
  • I know the switch is and the router is, and I assume the Realtek is too or, in the event I have a crossed over cable, it wouldn't have worked with the router...
    – Tom17
    Aug 11, 2014 at 22:06

1 Answer 1


Sorry to bother you all, it was a loose connector on the socket.

It still makes me wonder now, how did it work fine with the Router instead of the Switch. Or with the Switch and the Laptop instead of the Linux machine.

Anyway, all done :)

  • Don't forget to mark this as the accepted answer in a few days, so it doesn't sit around unanswered for eons! Aug 12, 2014 at 3:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.