0

Sorry, I'm a software guy, don't know much about networking. I saw similar posts, but I'm not able to make it work by following it. I'm on Mac. My IP is dynamic IP. My Mac is connected to a wireless router which is connected to my timer warner modem. I'm running a website at localhost:9000. Now, I want to access this site from the internet anywhere. I don't care about the domain name. I'm okay to use the IP address directly.

  1. I found the public Ip of my Mac by visiting http://www.whatismyip.com. It gave me x.x.x.x as external ip.
  2. Then I found my local ip in network in system preferences which is 192.168.1.2.
  3. I logged in to routerlogin.net and added HTTP Port forwarding external port starting 9000 to end port 9000 to internal port starting 9000 to ending port 9000 to internal ip 192.168.1.2.

Now I went to another machine (OS: windows 8) connected to another network, and typed the x.x.x.x:9000, but I couldn't access. Then I tried ping x.x.x.x from that windows computer, it didn't work, got timeout. What's is the problem? My firewall disabled on the mac.

Note, I don't have static IP, it's dynamic IP. Is that a problem? Is static IP must for this?

One more thing that I tried is, from the windows 8 (which is connected to another network), I went to whatismyip.com to get the public IP, and then went to my mac and pinged it, it worked.

Then, I tried to see if it works in the same network. So, I connected my android mobile to the same wireless router that Mac is connected. And then on my phone, I typed in chrome browser 192.168.1.2, didn't work. I typed 192.168.1.2:9000, didn't work. Typed x.x.x.x:9000, didn't work. But on my android terminal emulator, ping to my Mac's public IP x.x.x.x worked, and ping -p 9000 192.168.1.2 also worked.

  • "I logged in to routerlogin.net and added HTTP Port forwarding external port starting 9000 to end port 900 to internal port starting 9000 to ending port 9000 to internal ip 192.168.1.2." If this isn't just a typo, it's a problem, and likely where the mistake is. – 0xDAFACADE Aug 16 '14 at 4:06
  • @0xDAFACADE Sorry, yes, that's a typo. Edited now. – user66710 Aug 16 '14 at 4:07
0

I found the issue finally . The problem is with my grunt server (yeoman). I have to change hostname in gruntfile.js to 0.0.0.0 from localhost to enable the outside access.

0

Or you could install NeoRouter on both ends and avoid port forwarding on tje router alltogether and simultaneously avoid having to learn your public ip address each time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.