3

I am trying to install EclipseFP. I'm running OS X Mavericks.

I've tried following both the official installation instructions and the advice in this answer on SU, but I'm still having the same problem.

I can get the plugin itself installed painlessly using Help -> Install New Software..., Bbut when I restart and switch to the Haskell perspective, things start to go wrong.

The installation instructions tells me that I should receive a prompt to install BuildWrapper and Scion Browser. I do not receive this prompt. Furthermore, if I create a new Haskell project, my code has no syntax highlighting, and the Hoogle search feature does not appear to do anything. It's clear that the plugin is not set up correctly yet.

I've tried running cabal update in Terminal, but this does not change anything.

After several attempts going round in circles with this on Eclipse Juno, I uninstalled Eclispe and the Haskell Platform and performed a clean install of Eclipse Luna and the latest Haskell Platform. However, the problems are persisting.

I've tried going into Preferences to see if I could sort any of this out manually. I should initially point out that my GHC installation seems to be correctly references under Preferences -> Haskell Implementations

Under Haskell -> Helper executables, there are areas for configuring the options of both BuildWrapper and Scion Browser. At present, both are blank. I tried clicking the Install from Hackage... button beside each of them with no success; I receive an error message saying

Expected executable <workspace>/.metadata/.plugins/net.sf.eclipsefp.haskell.ui/sandbox/.cabal-sandbox/bin/buildwrapper not found!`

(replace buildwrapper for scion-browser and the message is the same)

The Eclipse console displays the following exception after doing the above with BuildWrapper:

src/Language/Haskell/BuildWrapper/GHCStorage.hs:313:32:
Not in scope: data constructor ‘MatchGroup’
cabal.real: Error: some packages failed to install:
buildwrapper-0.7.4 failed during the building phase. The exception was:
ExitFailure 1

and after doing it for Scion-Browser:

zip-archive-0.2.3.4 (reinstall) changes: text-1.1.0.0 -> 0.11.3.1
pandoc-1.12.3.3 (latest: 1.13) -http-conduit (new version)
Graphalyze-0.14.1.0 (reinstall) changes: pandoc-1.12.4.2 -> 1.12.3.3,
text-1.1.0.0 -> 0.11.3.1
cabal.real: The following packages are likely to be broken by the reinstalls:
pandoc-1.12.4.2
unordered-containers-0.2.4.0
aeson-0.7.0.4
scientific-0.2.0.2
case-insensitive-1.1.0.3
HTTP-4000.2.10
Use --force-reinstalls if you want to install anyway.

After receiving similar results as the above on previous attempts, I've tried using force-reinstalls and ended up at more dead ends.

I am at a loss as to what is wrong and how to solve this. I should point out that my GHC installation appears to be correctly configured under Preferences -> Haskell -> Haskell Implementations.

Apologies if any of this information is irrelevant, I'm just not really sure what is important and what isn't at this point.

Any help anyone could provide me with would be greatly appreciated.

0

I ended up installing BuildWrapper using cabal install buildwrapper --force-reinstalls, and it worked - I checked the Helper Executables section of EclipseFP preferences and both BuildWrapper and Scion-Browser are now there. I have no idea why this worked this time and not the last time I tried it, but if anyone else ever has this problem my advice is to do a clean install of the Haskell Platform and try again, as it seems that has fixed it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.