6

This problem has been around for quite some time and I have never found a solution. I even had to format once to get rid of it. And I'm not the only one with this: here, here and here.

Basically, all of a sudden all folders in my Windows XP setup become (grayed) read only

Grayed Read-Only

For many programs this really isn't a big deal. But I found that Eclipse doesn't work anymore!

Eclipse Problem

  • Tried re-installing applications, didn't solve the problem
  • Microsoft's solution doesn't solve the problem
  • Disabling simple file sharing doesn't solve the problem
  • Changing Read-Only properties to sub-files/folders doesn't solve the problem
  • Disabled my antivirus (Comodo Internet Security), didn't solve the problem

There have been many suggestions if you search but none of them worked. This could end up as another Works for Me thing and never be solved.

3
  • The check box is in the third state. There are some (but not all) files/folders that are read only. I've had the case where I can't seem to remove the read-only flag on a file, but I've not investigated further as it's not a problem. Your Eclipse folder is marked read-only - are there any others? Is there a pattern to which folders are read-only? Can you remove the flag from any or none? I know I'm not solving the problem here, but hopefully suggesting an avenue to explore.
    – ChrisF
    Jul 18 '09 at 20:11
  • 1
    possible duplicate of Having trouble with Windows XP Read Only Settings on a file
    – JdeBP
    Jan 9 '12 at 20:57
  • This is an outstandingly annoying problem. I've seen it in Windows 10. Settings are scattered all over the place and none of them does a thing. At the same time malware infects the system without even noticing these "security" measures. Fixed mine by using a healthy backup...
    – sixtytrees
    Jun 30 '16 at 14:26
3

That doesn't mean what you think it means. Notice that it's filled with a box rather than a checkmark. Checkboxes can actually have three states: checked, unchecked, and "other". What you're seeing is the "other" state, and you're seeing it because folders can't be marked read-only - there's not read-only bit to set for folders in the first place.

For your specific problem, permissions might have changed on the folder. But that's different than checking the read-only attribute.

1
  • Incorrect. It's a box because of the Windows theme. I've updated the screenshot with the Classic Windows Theme. Also, according to this source (mcpmag.com/articles/2006/…), the third state means "What the grayed-out and checked Read-only checkbox is telling you is that subfolders and files of the folder may have the read-only attribute and not the folder itself." or "it may imply that the folder is deemed a “special folder.” For example, folders that support customized views are special folders." Also, I've made sure about the permissions and ownership. Not solved.
    – pek
    Jul 18 '09 at 19:38
3

Open and Command Prompt and type in the following command:

attrib (drive):\* -r /s
4
  • 1
    Didn't do anything :(
    – pek
    Jul 18 '09 at 19:45
  • So the readonly box is still semichecked?
    – tsilb
    Jul 18 '09 at 20:12
  • Unfortunately, yes...
    – pek
    Jul 18 '09 at 20:46
  • I'm having the same problem and when I try this it appears to get "Access denied" for most or all folders. I'm running cmd.exe as administrator.
    – Stoney
    Dec 5 '12 at 11:46
0

Hm... if you disabled simple file sharing, did you go into the sharing options and make sure your account has premission to write?

1
  • Yes, I also made sure my account was the owner. For this folder and all sub-files/folders.
    – pek
    Jul 18 '09 at 15:17
0

You're not copying direct from a CD, are you? I've seen some "strange" issues with some files coming from CD to disk setting the read-only flag. The flag is easily cleared for the folder but it's still annoying.

1
  • A) No, even a folder I create is by default read only(!) and B) even if I unset the property it still remains!
    – pek
    Jul 18 '09 at 15:19
0

I have discovered that saving the documents to almost anywhere but My Documents works. Apparently the problem began after I set up a home network for internet access and printer sharing. I added two users to my wife's computer, one of which has admin rights, making a total of three users, two with admin rights.

1
  • This reply doesn't address the OP's question. And the question itself is based on a mistaken assumption. You should delete your answer. Apr 29 '20 at 19:54
0

No idea why Eclipse isn't working for the OP, but the confusion regarding the Read-only checkbox in the file folder Properties dialog needs to be cleared up.

The Read-only checkbox is not a status indicator!

enter image description here

Yes, the Hidden checkbox does serve as both toggle & inicator of a folder's Hidden attribute. But the Read-only checkbox, by contrast, is a tri-state switch:

  • Checked: Set attribute on files in folder
  • Cleared: Clear attribute on files in folder
  • Gray Square: Take no action

The action (if any) occurs when the OK or Apply button is clicked.

The "Take no action" state is the default state whenever the Properties dialog is displayed --- for every file system folder on every Windows system in the world. Easiest test is to create a new, empty folder & view the dialog. There's the gray square! So much for the mixed content theory! The way to determine if the Read-only attribute is set for any file or folder is to add the Attributes column to a Details view in Explorer: enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.