First of all, good night for all the readers of this help request.

I'll now describe my problem.

I'm connected trough a /n wireless network which should offer me 155MBP/s transfer rate, and my internet connection, as stated in the modem status if around 17Mbits/s. Still, any of my attempts to go over 2Mbits/s are useless.

I'e tried downloading files using HTTP protocol from my site. Tried Torrent, tried anything you could ever imagine that would consume more bandwith than 2mbits/s which is like 200kbp/s

So, i've ran speedtest.net with many servers, and the result is the same for all, 2mbits/s

I'm using Windows 8 PRO. Hackitaved (could have something to do with it? I know it sucks, but i lost my laptop original key D:)

My router is a RTA04N


  • I think this is a problem I've ran into before but first you should verify that this is not really related to the Wifi at all. To do that try using a wired connection and if that has the same problem I can probably help but you aren't going to like it because the solution will cost you some money.
    – krowe
    Aug 17, 2014 at 4:34

1 Answer 1


Your router may have a setting which taps the bandwidth shared across connected devices. Enter your router's control panel (by entering its IP address into the browser and entering the password, which should be written somewhere on the device) and look for anything that may be related to speed limitations.

Also, connect to the router with a cable (if possible with your device), disable your computer's wifi (to make sure the connection actually goes through the cable), and check if the limit applies then as well.

  • Sorry about the delay, i had issue with my work. Continuing, still not getting full speed from my modem and when i use the cable, it works like a wonder, 17mbps tops... awesome... but when i'm using wifi, 5mbps only :( Aug 22, 2014 at 21:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .