1

am using, php5+mysql+ldap . i had configured php and mysql with mediawiki. its working fine. But iwant to provide LDAP users authentication login and aswellas general users login.

i was installed ldapauthentication module from media wiki ldapauthentication page

The current situation is general can able to create an account in my mediawiki , but where as ldap users can not able to create.

Here am providing Localsettings.php.

      #########  edited by RAMKEE ################

   require_once( "$IP/extensions/Ldapauthentication/LdapAuthentication.php" );
     $wgAuth = new LdapAuthenticationPlugin();
   //require_once( "$IP/extensions/Ldapauthentication/LdapAutoAuthentication.php" );
    //AutoAuthSetup();
 # End of automatically generated settings.
 # Add more configuration options below.
  $wgLDAPDomainNames = array(
   'testADdomain',''
  );


  $wgLDAPServerNames = array(
  'testADdomain' => 'polyproxy.ramkee.local',''
  );


  $wgLDAPUseLocal = true;

  $wgLDAPEncryptionType = array(
  'testADdomain' => 'clear',''
  );


  $wgLDAPOptions = array(
  'testADdomain' => array( LDAP_OPT_DEREF, 1)
   );



  $wgLDAPPort = array(
  'testADdomain' => 389,''
  );



  $wgLDAPSearchStrings = array(
   'testADdomain' =>  'uid=USER-NAME,ou=people,dc=ramkee,dc=local'.''
  );

   $wgLDAPSearchAttributes = array(
   'testADdomain' => 'uid'
   );

   $wgLDAPBaseDNs = array(
  'testADdomain' => 'dc=LDAP,dc=ramkee,dc=local'
  );


   $wgLDAPGroupBaseDNs = array(
   'testADdomain' =>  'ou=group,dc=ramkee,dc=local'
  );


 $wgLDAPUserBaseDNs = array(
 'testADdomain' => 'ou=people,dc=ramkee,dc=local'
 );


  $wgLDAPWriterDN = array(
 'testADdomain' => 'ou=people,dc=ramkee,dc=local'
  );


 $wgLDAPWriterPassword = array(
 'testADdomain' => 'KnfMdMI0qiH9HZBQw7JkqLyEni/wp34x'
  );


 $wgLDAPWriteLocation = array(
  'testADdomain' => 'ou=people,dc=ramkee,dc=local'
   );



   $wgLDAPAddLDAPUsers = array(
   'testADdomain' => true
   );


  $wgLDAPUpdateLDAP = array(
  'testADdomain' => true
  );


 $wgLDAPRetrievePrefs = array(
 'testADdomain' => true
 );





$wgLDAPDisableAutoCreate = array(
'testADdomain' => false
);

$wgLDAPDebug = 10000;

$wgMinimalPasswordLength = 1;

$wgLDAPGroupUseFullDN = array( 'testADdomain' => false );

$wgLDAPLowerCaseUsername = array(
 'testADdomain' => true
);

 $wgLDAPGroupObjectclass = array(
 'testADdomain' => 'groupofuniquenames'
 );

$wgLDAPGroupUseRetrievedUsername = array( 'testADdomain' => false
);


$wgLDAPGroupNameAttribute = array(
'testADdomain' => 'cn'
);

$wgLDAPGroupsUseMemberOf = array(
'testADdomain' => false
);



$wgLDAPUseLDAPGroups = array(
 'testADdomain' => true
);


$wgLDAPGroupsPrevail = array(
'testADdomain' => true
);


    #wgLDAPRequiredGroups = array(
    # 'testADdomain' => array(
    #   'cn=admin,ou=groups,dc=ramkee,dc=local',
    #   'cn=chulbul,ou=people,dc=ramkee,dc=local'
    # )

    #;

whenever i try to create a account for ldap , it is showing that you dont have rights to update the database.(my database is mysql) while account creation the following error am getting

enter image description here

and while log in as administrator it is accepting (administrator is not there in LDAP)

my ldap is also working , port 389 is oprned, and ldapsearch -x is also working. But i dont where i did mistake. one admin can able to login, general users also not able to login. am struggling for the past 3 days. any one can help me

1

I found my self where i did mistake , here am providing my localsettings.php. if any one need it, follow this you might be succeed

after creation of successful mediawiki page you will get fresh localsettings.php. in that just add the following lines. then you will get authenticate to your LDAP databse.

Those who are there in LDAP database those need not to create an account in our mediawiki, they can directly login with out creation of wiki account.

ramkee.local ismy domain name. polyproxy.ramkee.local is my LDAP server name

 require_once 'extensions/LdapAuthentication/LdapAuthentication.php';

 $wgAuth = new LdapAuthenticationPlugin();

 $wgLDAPDomainNames = array(
 'ramkee.local',
 );


 $wgLDAPServerNames = array(
'ramkee.local' => 'polyproxy.ramkee.local',
 );



 $wgLDAPEncryptionType = array(
 'ramkee.local' =>  'clear',
 );

 $wgAuthLDAPBindDN = array( 'ramkee.local' => 'cn=admin,dc=ramkee,dc=local');
 $wgAuthLDAPBindPassword = array( 'ramkee.local' => 'safesquid');

 $wgLDAPPort = array(
 'ramkee.local' => 389,
 );


 $wgLDAPSearchAttributes = array(
 'ramkee.local' => 'uid'
 );

 $wgLDAPBaseDNs = array(
 'ramkee.local' => 'dc=ramkee,dc=local',
 );

 $wgLDAPDebug = 3;

 $wgDebugLogGroups["ldap"] = "/tmp/wikildapdebug.log" ;

if you get any errors please letme know. Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.