2

I have a Toshiba Class 10 64GB microSD that I want to use in a tablet (Cyanogenmod 11) by formatting it ext4.

So I did the usual thing (under Fedora 20): created a single Linux partition with sfdisk, then created the ext4 partition with mkfs.ext4 /dev/sdf1 without problems. Then, I just tried to mount it with mount -t ext4 /dev/sdf1 /mnt/sd/, but I got a journal error:

 JBD2: no valid journal superblock found
 EXT4-fs (sdf1): error loading journal 

Tried googling this, but didn't find anything useful.

Any ideas?

Thanks!

L.

8
  • If you have Windows handy, I suggest checking the card with h2testw. It might simply be broken. Yes, this can also occur with new devices.
    – Daniel B
    Aug 17 '14 at 19:44
  • 1
    @DanielB: mkfs.ext4 -c shows no errors. Aug 17 '14 at 19:46
  • 1
    Additionally please understand, that ext4 is an extremely poor fit for an SD card - it has a static journal, and SD cards typically have static block mapping - this means, that you will wear out the card in no time. Aug 17 '14 at 20:04
  • @EugenRieck: My SD card was formatted exfat, but exfat has a nasty bug with caching files (acknowledge by Microsoft) that prevents to copy many small files on it in reasonable time. I've 55000 files to load to it, and failed many times because of this. I've my pen drives formatted ext3/4 for a long time now, without problems. Which problem are you referring to? Thanks. Aug 17 '14 at 20:29
  • He’s referring to repeated writes to the same block(s). Because SD cards don’t do wear leveling, this block will be destroyed in no time. Buuut you can also use ext4 without journaling. :)
    – Daniel B
    Aug 17 '14 at 21:11
3

Try formatting without journaling and it should work:

mke2fs -t ext4 -O ^has_journal /dev/sdf1

Being an SD card, you probably don't want journaling enabled.

2
  • 1
    Welcome, and thanks for answering this question. Would you consider adding a few sentences to your answer to explain why journaling would not be desirable on an SD card?
    – fixer1234
    Nov 27 '14 at 4:40
  • I already said this in a comment to my original post. Anyway it seems it is a hardware problem. Nov 28 '14 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.