1

The Problem:

  • The Properties dialogue box for text files has lost its accustomed Change button
  • From the list of extensions in Control Panel\Programs\Default Programs\Set Associations, the .txt file extension is missing
  • In the Open with dialogue box that can be accessed by right-clicking a text file, and then selecting Open with, and then Choose default program..., the option to Always use the selected program to open this kind of file is unchecked and grayed out
  • The .txt file extension is currently associated with Explorer, which, for the above reasons, I do not know how to change.

The Cause:

This all came about because I accidentally set the .txt file extension to open with Explorer. Clicking on a .txt file now causes Explorer to attempt to open it several times a second, until Explorer crashes, or I restart the system.

Subsequent failed attempts at solving the above mess include:

  • Trying to set a new file association for the .txt extension, using Assox1000
  • Trying to set the Open with dialog box option to Always use the selected program to open this kind of file as unchecked by default, by applying (unsuccessfully) the registry edit that apparently should accompany pasting MyOpenAs.dll into System 32
  • Using unassoc_1_4 to unassociate the .txt extension from everything
  • Using filetypesman-64 to delete the .txt extension altogether
  • Running sfc /scannow to fix missing Windows components
  • Using CCleaner to fix the registry
  • Applying a backup of an earlier registry condition

I'm feeling very tired and very foolish, right now, and would hugely appreciate any genius suggestions!

1

From here:

http://answers.microsoft.com/en-us/windows/forum/windows_7-files/windows-7-endless-explorerexe-chain-on-file-type/9b7d0c94-9ceb-4324-8fd0-4c29582154c6

I learned this:

Found it in the Registry. Only proceed if you are insanely frustrated with this issue.

Look at the value in the following key in the registry. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.jar\UserChoice

Does it look something like Windows\explorer.exe? Not good.

Delete the following key in the registry. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts.jar\UserChoice

Now, you can go to an Explorer window and choose a new default program for .jar files.

I applied this advice to the .txt extension, and it worked.

Unfortunately, the New Text File option in the Explorer context menu was garbled. I managed to restore that from the following sage words (from http://articlebin.michaelmilette.com/new-text-document-context-menu-missing-after-associating-notepad-with-txt-files/):

you can re-create [a missing context menu item for New Text Document] by copying and pasting the following as text file into Notepad or Notepad++ and saving it as fix-new-text-document.reg. Last, double click on the file to import it into the registry. Windows will likely ask you to confirm that you really want to do it.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.txt]
"PerceivedType"="text"
@="txtfile"
"Content Type"="text/plain"
  • I only needed to delete the reg key to make this work. Didn't need the 2nd step. – ThunderFrame Sep 21 '16 at 6:10
0
  1. Open Windows Explorer
  2. Select a file with the extension you want to change the association to
  3. Hold the shift key and right click the file
  4. Select "Open with..."
  5. Select "Choose default program..."
  6. Select the program and click OK
  • Thank you, LDC3, for your suggestion. Opening text files with whatever program I want isn't actually the issue, though - I can also drag and drop. Your advice only works as a one-off, and doesn't un-associate the extension from Explorer. Without or without holding Shift, the option to 'Always use the selected program...' is still locked. Trying to open another text file in the normal way (I use text files for almost everything) then results in the same manic response from Explorer, necessitating a system restart. – Julian Lees Aug 18 '14 at 3:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.