2

I am trying to SSH into a virtual machine I have set up in virtual box from my Windows 7 host machine. I would like to make several development machines and ssh into them from my host machine, as well as ping them and so on. Inside of virtualbox, I have my VM selected (openSUSE 12.3) and I right click and go to settings, select the network tab, enable adapter 2 with these settings:

enter image description here

When I spin up the machine and run the ifconfig command, I do not see the adapter 2 settings. Here is what I get:

enter image description here

You can see there is not eth1 listed. From what I understand, I need the IP address of the eth1 network adapter to ssh into the machine. Is this not the correct process to add this adapter inside a virtualbox VM?

EDIT

dmesg | grep e1000:

enter image description here

migrated from serverfault.com Aug 18 '14 at 14:03

This question came from our site for system and network administrators.

  • Is there any reason why you are not using bridged networking with your VMs? This way they would appear in your LAN, and you wouldn't need two interfaces to every VM for separate host / Internet access. – Tero Kilkanen Aug 18 '14 at 16:00
  • Is the Adapter type the same both on Adapter 1 / Adapter 2? What is the output of dmesg | grep e1000 in the VM? – Tero Kilkanen Aug 18 '14 at 16:02
  • @TeroKilkanen No, there is no reason I'm not doing that. I'm not aware of the pros/cons of using either. – smilebomb Aug 18 '14 at 18:11
  • @TeroKilkanen Please see my edit. Adapter 1 is NAT. – smilebomb Aug 18 '14 at 18:18
  • I would switch Adapter 1 to Bridged mode and disable Adapter 2. This is the easiest way to achieve your goal, assuming that you have a LAN set up with a DHCP server that can provide configuration to your VM. – Tero Kilkanen Aug 18 '14 at 18:31
1

I don't see anything wrong with your Virtualbox setup offhand. I have the same setup with an Ubuntu VM, and it works fine. I believe the issue is that the OS running inside the guest has to see both network cards and set up both interfaces. Some versions of Linux will do that automatically, and some won't.

For example, here is a question on the Unix stackexchange from someone having this problem on Debian. In that case, he had to manually add a line to a config file to enable the second network interface.

Unfortunately, I can't give you specific instructions for OpenSUSE. This page appears to be SUSE's documentation on the subject (and you can see the link for using YaST on the left side). It looks like you should be able to configure the interface from YaST. Alternately, it might be necessary to edit some ifcfg-* files in the directory /etc/sysconfig/network.

  • I agree, the problem here is that the other network interface isn't configured inside the guest OS. – Tero Kilkanen Aug 18 '14 at 18:30
  • The problem was that the interface was not configured automatically. I was able to configure it through network devices in yast. Thank you. – smilebomb Aug 18 '14 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.