8

I've recently tried installing .NET 3.5 for an application on Windows 8.1. I used the OS's popup thing to download/install .NET 3.5 and always get error code 0x800F0906.

Upon further research, I found I would have to pop in my Windows 8 CD and install it with this command, where "E:\" is where my CD is mounted:

Dism /online /enable-feature /featurename:NetFx3 /All /Source:E:\sources\sxs /LimitAccess

This and any derivative of it (e.g., removing /LimitAccess) has not worked for me and has either given me the same error code (0x800F0906) or a different one, 0x800F0081F. I've even copied the sxs folder to my hard drive, just in case something was going on with the CD Drive, only to have the same results. In that case, I used this command line:

Dism /online /enable-feature /featurename:NetFx3 /All /Source:C:\dotnet35 /LimitAccess

I find this surreal because in both cases, the files are indeed there but the program thinks it's not. Here's the CBS.log file.

Any ideas on how to fix this? Any help is very appreciated :)

EDIT: I now have a proper dism.log file, I'm not sure what happened to the last one or why it did that. Here's the link to the new log file. It's interesting to note that it doesn't recognize some of the commands in the script such as "featurename" or "source".

  • Are you using right installation media (OS language, x86/x64 etc)? – Merzavets Aug 18 '14 at 21:20
  • Yes! I'm using the same Windows 8 disk I used to install the OS. It's a Windows 8 x64 (not 8.1) disk, so I'm not sure if there are any conflicting issues because of this since I've updated to 8.1 through the OS (that is, through Windows Update/the Store) – Austin Meadows Aug 18 '14 at 23:22
  • I have now updated the question with a proper dism.log file. – Austin Meadows Aug 18 '14 at 23:58
  • @AustinMeadows Can you install it by running the command optionalfeatures? – Louis Aug 19 '14 at 0:14
  • have you installed a MUI pack? – magicandre1981 Aug 19 '14 at 4:21
13

I had the same problem and solved it as follows: I noticed that two recent Windows updates refer to .NET Framework 3.5. I uninstalled them both and then was able to install .NET Framework 3.5 from Control Panel.

I'm not sure if was necessary to uninstall both updates. They are KB2966826 and KB2966828.

  • apologies everyone, I have been busy with college stuff. This solved my problem! After uninstalling those, the installation of .NET 3.5 went through flawlessly. Thanks! – Austin Meadows Aug 21 '14 at 22:08
  • 1
    Finally a solution that worked. Been looking at solutions for about 5 hours until I found this thread. Thanks a bunch! – NoLifeKing Aug 23 '14 at 20:46
  • 1
    I've been spending all night downloading Windows 8 Enterprise trial just so that I can have the installation media mounted and install NET 3.5 from DSIM command line, which did not work either. But this one works, and I can't believe it's that easy. Million thanks! – Hendra Anggrian Aug 28 '14 at 8:18
  • 1
    Confirming this works. After 5 hours of running around, getting dvds off my friends, finally found this post. Turns out Windows Update installs TWO updates to .NET 3.5 even when you don't have it installed. Wierd. – Kitet Aug 28 '14 at 10:34
  • MS created a hotfix to remove the ones that block the feature install - support2.microsoft.com/kb/3005628. They recommend using that, then installing the feature, then re-running windows update. I hate technology... ;-) – Peter Mounce Oct 8 '14 at 23:14

protected by Community Aug 23 '14 at 0:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.