0

I have installed Tuleap(as per full installation from user guide) in CentOS 6.5. All the files got installaed. I have tried to login with Tuleap domain name. And I gave credentials Login Name and Password : admin / siteadmin and clicked on login. But its not getting login. Its return same login page.

And I not finding automatically generated passwords file .tuleap_passwd in root (/root/.tuleap_passwd not exist)

I could see anaconda-ks.cfg, install.log, install.log.syslog and todo_tuleap.txt only in /root/

  1. Please suggest and correct me if I have done wrong.
  2. Please suggest me the correction to get login .
1

When I give credential admin / siteadmin, there no error showing but redirecting to same page. when I give some other credentials its showing error like invalid Password or User Name

......................

Below is the values in /roor/.tuleap_passwd

[root@HCL-PC /]# vi /root/.tuleap_passwd

Mysql user (root) : wA4KTtl5K
Codendiadm unix & DB (codendiadm): QMmcLBQ0g
Mailman siteadmin: 71VAp7kW1
Openfire DB user (openfireadm): ttkAxiyB7
Libnss-mysql DB user (dbauthuser): 8XVl04Uw0

So from the above with which credential (username / password) I have to login to Tuleap

1

Don't know if you ever figured it out but I had the same issue and after some debugging in my case it turned out to be because I connected to the site via IPv6 which Tuleap apparently can't handle (right now).

The issue is that the column in the database that logs the IP address for the session is a CHAR(15), causing an IPv6 to be truncated upon insert.

I was able to easily fix the issue by increases the maximum length of the column in the database.

First connect to the database with mysql -uroot -p tuleap (you can find the password in /root/.tuleap_passwd if you haven't changed it yet) and then do:

ALTER TABLE session CHANGE ip_addr ip_addr VARCHAR(45) NOT NULL DEFAULT '';

After that I was able to login using admin / siteadmin.

0

The login combination "admin/siteadmin" has been invalidated for last few releases.

The file .tuleap_passwd is a hidden file that should be in /root and discoverable with

ls -a

If this is not the case then this is a bug and needs to be logged along with Tuleap version you tried to install.

One point you raise is that you return to the same login pane. It would help if you said whether any error messages are shown when that happens as this would indicate whether the credentials you entered are invalid or there's a config issue.

[update]

admin/ siteadmin may only be invalid for docker installations and this where the confusion was coming from.

The fact that there is no "invalid username or password" message points to another problem. Maybe your local.inc or apache config surrounding https and ssl.

0

As of today's date, the file with passwords is in /data/root.

russellh@ubuntu1:~$ docker ps
CONTAINER ID        IMAGE                COMMAND                  CREATED             STATUS              PORTS                                                                                 NAMES
b0190aa87423        enalean/tuleap-aio   "/usr/share/tuleap/t…"   29 minutes ago      Up 29 minutes       192.168.16.164:80->80/tcp, 192.168.16.164:443->443/tcp, 192.168.16.164:2222->22/tcp   cranky_jones
russellh@ubuntu1:~$ docker exec -it b0190aa87423 bash
[root@b0190aa87423 /]# cd /data/root
[root@b0190aa87423 root]# ls -a
.  ..  .tuleap_passwd
[root@b0190aa87423 root]# cat .tuleap_passwd
Mysql user (root) : 3mGFLb8Fnnsklfj
Codendiadm unix & DB (codendiadm): W5fo8o9dEJgG32I
Libnss-mysql DB user (dbauthuser): 0iiRqPaRCLfcSzR
Site admin password (admin): rpuOtUWJk7uUcNk
-1

I had the same problem after submiting login form I was redirected to login form with no error message again and again

I found out that is was a web browser cookies issue...

Clean cookie form your web browser (or change web browser)

hope this help

-1

So what i see from my docker installation

- WHAT TO DO TO FINISH THE TULEAP INSTALLATION (see /root/todo_tuleap.txt)
- Your domain name is localhost
- Automatically generated passwords are stored in /data/root/.tuleap_passwd
- Customize /etc/tuleap/conf/local.inc and /etc/tuleap/conf/database.inc
- You may also want to customize /etc/httpd/conf/httpd.conf
- Customize /etc/tuleap/site-content information for your site.
-   For instance: contact/contact.txt 
- 
- Default admin credentials are login: admin / password: 7BIXNKJ8bGKiC4A
- CHANGE DEFAULT CREDENTIALS BEFORE FIRST USAGE
- Auto generated passwords (mysql, application, etc) are stored in /data/root/.tuleap_passwd

so:

login: admin 
password: 7BIXNKJ8bGKiC4A

should do the trick

  • Based on previously confirmed information. The default admin account is disabled by default and a previous answer already suggest looking in the .tuleap_passwd` file. – Ramhound Nov 3 '16 at 17:45

protected by Community Nov 3 '18 at 11:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.