I recently heard about Breach, a Node.js based browser. I was following the instructions from here to install it but got the following error :

breach-v0.3.22-alpha.6-linux-x64/__AUTO_UPDATE_BUNDLE__/exo_browser/exo_browser: cannot execute binary file: Exec format error

After some googling, I found that it is because I am trying to install the 64 bit package on the 32 bit Ubuntu installation. I tried to find 32 bit package of the same but ended up with no luck. The browser is only available in 64 bit packet(as far as i know).

So, My question is :

Is it possible to somehow install it on the 32 bit OS or if any program available which can run 64 bit applications on the 32 bit OS.

I have been googling around and found no help. Can anyone help me?

I am using Ubuntu 14.04 (32 Bit).

2 Answers 2


If you have a 32-bit OS, then you need to have 32-bit applications. The only way to get 64-bit applications to run is to run them under a 64-bit OS. BTW, it is possible to run 32-bit applications under a 64-bit OS.

So the suggestion here:

  1. Find and use the 32-bit package

  2. Find the source, do a full recompilation for a 32-bit system, install and use that.

  3. Upgrade your system to a 64-bit Ubuntu.

  • Thanks for your response, but the 32-bit package is not yet available. Aug 19, 2014 at 15:09

You can't run 64-bit executables on a 32-bit kernel:

Can I run 64-bit executables on a 32-bit Linux?

A poster on that thread suggested using an emulator (i.e. emulating a 32-bit architecture).

This may sound a bit unhelpful, but it's usually best to go with a 64-bit install unless you have a specific need for 32 (i.e. hardware-related) as it's easier to run 32-bit software on a 64-bit kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.