I am experiencing an issue with Visual Studio Ultimate 2013 hanging with a "Waiting for Operation to Complete" message whenever I launch it.

Microsoft Visual Studio - Waiting for a required operation to complete. This dialog will close when the operation completes.

This dialog appears every time I launch Visual Studio and never disappears. As of the writing of this post, Visual Studio has been doing this for a half-hour. This is my fourth attempt at trying to get Visual Studio to start. Does anyone have any idea how to solve the problem? I am using Visual Studio Ultimate 2013 with Update 2 on Windows 8.1 Pro x64.

  • 1
    Are you just trying to open VS via a link to it directly, or are you trying to open it by double-clicking a solution? Have you tried starting it while logged in as a different user? How about while in Safe Mode? Have you tried repairing/reinstalling VS yet? Have you trying starting VS with the /log switch, so you can examine the startup logs? – Ƭᴇcʜιᴇ007 Aug 19 '14 at 19:54

Delete the Solution's .suo (Solution User Options) file. I'm not exactly sure why the hang-on-launch happens. I assume that some option gets into a weird state, and this forces them all to reset.

Here's a related thread, where the same conclusion is reached: when .suo files become corrupt 'odd things happen'.


Visual Studio 2013

Power failure in which not using UPS , machine loses power --> 3 times now VS 2013 would hang and my solution I found was to DELETE everything in this folder


However THIS time it is not recovering.

I do have Visual Studio 2015 and it NEVER happens to VS 2015.


  1. I opened a different solution in VS 2015 which opens fine
  2. I then attempt to open the same solution that will NOT open in VS 2013 IN VS 2013 and it NOW WORKS.

:/ ODD I know.


In my case, VS 2013 Professional was hanging on startup because the license was no longer valid.

Last item in the log file:

    <time>2015/07/13 20:11:05.051</time>
    <description>myemailaddrs@gmail.com signed in for IDE user</description>

And on the msdn.microsoft.com subscription page: "Your subscription is no longer active, contact your administrator."

I had to get an updated subscription from my employer.

  • Did you have this problem recently? Visual Studio 2015 is slated for release exactly a week from today and upgrades to it will be free if you have a 2013 Community, Professional, Premium, or Ultimate license. I wonder if Microsoft is making some change to the license before releasing. I'm not sure if that is actually the case, I'm just speculating. – DaveTheMinion Jul 13 '15 at 21:39
  • 1
    In my case the problem was on my end, due to my employer deactivating our Professional licenses and activating Premium, so all I had to do was install Premium and switch over. However, it would have been a lot more helpful if MS had coded VS to tell me that there was an issue with my license instead of just hanging. – Kerry Randolph Jul 14 '15 at 15:13
  • What @KerryRandolph ran into is exactly what happened to me. Really wish VS would give you a more appropriate response rather than just hanging. – dispake Jul 23 '15 at 23:27

Restarting my computer for the fifth time seems to have solved the problem. I do not know how or why, but it seems to have solved the problem.

  • lol . Seems that restarting the computer is a universal solution for every problem ;) – user11207 May 26 '15 at 7:46
  • @user11207 At times it does seem that way. – DaveTheMinion Jul 13 '15 at 21:33
  • "60% of the time it works 100% of the time" ~ anchorman quote – Tom Stickel Sep 25 '15 at 18:02
  • I'm loving the person that downvoted my answer just because it is generic. I marked it as the answer because it's what worked for me. – DaveTheMinion Sep 25 '15 at 18:09

Run VS in safe mode using the command "devenv /SafeMode" Open the solution. It won't load every module, just wait for it to complete. Close VS. Re-open VS normally and open the solution. It solved problem for me


The one thing that helped me is updating the package. Open the solution that is having this "waiting for internal operation to complete" then Go to Tools - Nuget Package Manager - Package Manager Console. Then run "Update-Package". After the update, I was able to close and open the solution with no problems. Hope this helps your issues.


Run devenv.exe /ResetSettings from a VS 2013 developer command prompt.

  • It worked for me. Experienced the same issue. – Anonymous Jul 4 '17 at 15:04
  • I'll keep this in mind for if I experience any more issues, but at this point I am actually using Visual Studio 2017 Enterprise instead. – DaveTheMinion Jul 4 '17 at 15:16
  • It would be good to describe the function of devenv.exe and why it should fix the issue. – Stese Jul 4 '17 at 15:20
  • I'm not familiar with Visual Studio, but this sounds like a Catch-22 — how do you get to a VS 2013 developer command prompt in the first place if you can't get Visual Studio to start? – Scott Jul 4 '17 at 17:34
  • @Stese devenv.exe is the main executable for Visual Studio. – DaveTheMinion Mar 1 '18 at 2:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.