Worked fine a week ago. Yesterday when I plugged headphones into my Asus laptop, I got sound both from headphones and speakers. Today after system crash (not sure what was the reason) when I plug headphones, speakers are muted automatically but there is no sound from headphones.

# lspci -v
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
    Subsystem: ASUSTeK Computer Inc. Device 124d
    Flags: bus master, fast devsel, latency 0, IRQ 45
    Memory at f7a10000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 2
    Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    Capabilities: [100] Virtual Channel
    Capabilities: [130] Root Complex Link
    Kernel driver in use: snd_hda_intel

# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC270 Analog [ALC270 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I've found few suggestions to add options snd-hda-intel model=auto or options snd-hda-intel model=laptop to /etc/modprobe.d/alsa-base.conf. I did that too, restarted alsa-utils but that didn't help at all.

Also tried this superuser answer already. No luck either - auto mute is enabled. Also channels aren't muted:

┌───────────────────────────── AlsaMixer v1.0.25 ──────────────────────────────┐
│ Card: HDA Intel PCH                                  F1:  Help               │
│ Chip: Intel PantherPoint HDMI                        F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All             F6:  Select sound card  │
│ Item: Master [dB gain: -16.50]                       Esc: Exit               │
│                                                                              │
│    ┌──┐       ┌──┐       ┌──┐       ┌──┐       ┌──┐                          │
│    │  │       │▒▒│       │▒▒│       │▒▒│       │▒▒│                          │
│    │  │       │▒▒│       │▒▒│       │▒▒│       │▒▒│                          │
│    │  │       │▒▒│       │▒▒│       │▒▒│       │▒▒│                          │
│    │  │       │▒▒│       │▒▒│       │▒▒│       │▒▒│                          │
│    │  │       │▒▒│       │▒▒│       │▒▒│       │▒▒│                          │
│    │  │       │▒▒│       │▒▒│       │▒▒│       │▒▒│                          │
│    │▒▒│       │▒▒│       │▒▒│       │▒▒│       │▒▒│                          │
│    │▒▒│       │▒▒│       │▒▒│       │▒▒│       │▒▒│                          │
│    │▒▒│       │▒▒│       │▒▒│       │▒▒│       │▒▒│                          │
│    │▒▒│       │▒▒│       │▒▒│       │▒▒│       │▒▒│                          │
│    │▒▒│       │▒▒│       │▒▒│       │▒▒│       │▒▒│                          │
│    ├──┤       ├──┤       ├──┤       └──┘       └──┘       ┌──┐     Enabled   │
│    │OO│       │OO│       │OO│                             │MM│               │
│    └──┘       └──┘       └──┘                             └──┘               │
│     49      100<>100   100<>100   100<>100   100<>100                        │
│<  Master  >Headphone   Speaker      PCM     Mic Boost    S/PDIF   Auto-Mute  │
└──────────────────────────────────────────────────────────────────────────────┘

Basically I'm using vanilla Debian Wheezy with all updates installed. Everything worked fine few days ago. I can't recall if I installed any alsa related updates recently.

  • Run alsamixer in a terminal. Verify that the output channels aren't currently muted (use M to switch mute on/off). Let me know if that helps and if it does help I'll type up a proper answer. :) (ALSA often defaults to muted, and if your audio settings get reset for any reason -- which they shouldn't -- it's easy to get tripped up by that.) – a CVn Aug 19 '14 at 20:18
  • @MichaelKjörling channels aren't muted. – SiliconMind Aug 19 '14 at 20:24
  • Aw drat. Well, it was worth a shot. Can't think of anything off the top of my head, then. – a CVn Aug 19 '14 at 20:25
  • I had a similar sort of problem a while back, and the "fix" was to replace the defective jack (i.e., new mobo under warranty from HP). It was a hardware problem, not a software or driver issue. You could try booting with a Knoppix or Ubuntu LiveCD and see if you get the same results; this might help point towards a hardware issue, rather than software. – DarkMoon Aug 19 '14 at 21:03
  • @DarkMoon damn, that's not the answer I was hoping to read :( Did you have the same symptoms? Sound from both, speaker and headphones and then only speaker? – SiliconMind Aug 20 '14 at 8:56

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.