1

I have a hard drive, and it has always worked easily for me before on my windows 7 computer. I tried plugging it in to said computer and it would be visible in D&P (Devices and Printers), but not visible in Computer. I couldn't access the data on it. Through the magic of Google, I found a forum where someone had a similar problem, and somebody told him to add a letter to the drive through diskpart. I named my hard drive A: with no errors or problems.

Now I can see the hard drive in Computer, but I am getting this error: "You don't currently have permission to access this folder. Click Continue to permanently get access to this folder."

When I click Continue, I get this error: "you have been denied permission to access this folder. To gain access to this folder, you will need to use the security tab."

When I click on 'security tab', it brings me to the properties of the drive, but there is no security tab. A similar question has been asked here and here, but for both of those questions, they have access to the security tab, which I don't. Also, it says underneath the drive that it that it has 196 MB free of 196MB. I don't remember exactly how much storage it has, but it has at least 20 gigs, and probably 50-100. It also has some files that I'd rather not lose.

When I run the command promt as an administrator, I can change directories from C: to A:, but when I try to list the contents of A: I get this:

 Volume in drive A is EFI
 Volume Serial Number is 3F3C-1AF6

 directory of A:\

File Not Found

Have I lost all the files and the space on my drive? How can I get access to it again?


EDIT:

More useful information that I have learned since posting this question. A: is listed as EDF under Hard Disk Drives not Devices with Removable Storage as I would expect it to. There is also no eject button when I right click. I went to D&P and ejected it from there, and unplugged it. It is still under Hard Disk Drives, but its name is shown as Local Disk (A:) instead of EDF. When I plugged it back in, it still shows up as Local Disk, and behaves as if it wasn't plugged in. It is still visible in D&P.


Here's how my drives appear in Disk Management:

enter image description here

  • Please provide a screenshot of diskmgmt.msc. Make sure the window is expanded so we can see all of the columns and items in the volume list, and all of the HDDs (and their partitions) in the lower section. I've got an idea of what your problem (probably) is, but need this information to confirm. – Iszi Aug 20 '14 at 7:20
  • I am not familiar with diskmgmt.msc. I will look around for it, but in the mean time, could I have a quick explanation of where it might be/what it does? – James Aug 20 '14 at 7:22
  • Start->Run diskmgmt.msc It's a Microsoft Management Console plug-in for Disk Management, which is included in Windows. – Iszi Aug 20 '14 at 7:23
0

It seems you have two problems here. One is a simple matter of user error. The other, I'm afraid, is going to be a bit trickier.

  1. You're mounting the wrong partition. The "EFI" partition you are mounting is just a partition to hold the bootloader for systems that use UEFI. This partition will not contain any of your data and generally should not be messed with.
  2. Your data partition is not formatted. Notice how the two partitions on Disk 0 have "NTFS" listed for their File System, but the partitions for Disk 1 don't have anything. Having nothing listed for File System is normal for an EFI System Partition, Recovery Partitions, and some other special-use partitions. However, it is not normal for any partition that contains an operating system, programs, and/or user data.

While I can't say exactly what happened to your drive, I can tell you that you won't be able to read it by any normal means while Windows is not detecting a file system on the data partition. You will probably need some advanced data recovery tools to get anything off of the drive, if it's possible at all.

One thing you should not do, until you've gotten all retrievable data copied to another drive, is format the drive. Formatting the drive will make later data recovery much more difficult, if not impossible by common means.

| improve this answer | |
  • Okay, this might be a different question entirely, but how do I go about fixing this? I am guessing that I would have to start with umounting the EFI and then remounting the actual data partition. Is that correct? Where would I go from there? – James Aug 20 '14 at 21:07
  • @user3524982 That wouldn't help at this point. Like I said, Windows can't read the volume if the format isn't recognized. You'll need specialized tools for that. What's good for it these days, I'm not sure - haven't been in that market for awhile. Might want to drop a question on Software Recommendations for that. – Iszi Aug 20 '14 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.