I am having a problem with the wired network connection. My Wireless connection works fine but when I try to connect with the wired adapter, it stays limited and no connectivity. I don't even have access to the local network. This isn't a router problem since my collegue is on the same network and doesn't have any problems.

I tried resetting the TCP/IP stack and WINSOCK entries with the following commands:

netsh int ip reset reset.log

netsh winsock reset catalog

I restarted the PC but with no luck.

My best guess is that the NIC has failed. However, the light is still blinking so I don't know if it failed.

Any suggestions??

Many thanks


Unless you've followed a troubleshooting procedure that involves both known-good patch cable(s) (at both the wall-jack and patch panel) and a known good switch port, you are prematurely diagnosing the failure.

Try your collegue's patch cable and walljack port, since they're both known good, and are obviously connected to known good patch panel port, patch panel cable, and switch port. If it still doesn't work then you should go about diagnosing a NIC hardware failure (booting a known-working OS and seeing if the NIC still fails, etc).

It's far too often that one jumps to conclusions w/o having tested all the possible factors (changing one thing at a time, testing for success, and changing things back to the previous configuration at each step of the way). Rein in your desire to get to the root of the problem on the first try, and pursue a methodical troubleshooting procedure-- it won't fail you, and you'll likely solve the problem before others who take a more "cowboy" approach.

| improve this answer | |
  • The wall jack goes to the hub. Both me and my collegue are connected to the same walljack, What I can change is the network cable. Maybe this is not working. – Chris Dec 4 '09 at 13:41
  • 1
    +1 for the methodical troubleshooting procedure - had the same case finding out, that the problem was the cleaning lady unplugging the LAN cable... :) – blank3 Dec 4 '09 at 13:53
  • lol... If you read my answer you will see that I fixed the problem. However there is something wrong with the DHCP client or server. In the services, it is set to start automatically and enabled. However, if I try to renew to IP when using obtain automatically I get the following error: An error occured while renewing interface Local Area Connection : unable to contact your DHCP server. Request has timeed out. Any ideas? – Chris Dec 4 '09 at 14:15
  • Another troubleshooting step is to verify the routes and make sure that all the routes are copacetic. – Spig Dec 4 '09 at 14:16
  • 1
    +1: Always always always check things that can be physically wrong with a problem. I can't count how often the network gets blamed incorrectly. – sclarson Dec 4 '09 at 14:47

Check the basics: Make sure TCP\IP is bound to the NIC. Does the NIC have a static ip address or is it getting a DHCP assigned address? Check the ip configuration and make sure it has an ip address that's valid on the local network. Next would be to plug it into another switch port and see if that changes things. After you establish connectivity to the local network check that it has internet connectivity by checking the default gateway ip address on the NIC and check that you have the right DNS servers configured on the NIC.

| improve this answer | |

So... turns out nothing is wrong...

I copied the IP that the Wireless adapter was using and inserted everything manually in the TCP/IP config.

However, I am still bugged why it is not connected with the Obtain an IP address automatically. Up until a week ago, it was connecting with these settings.

When using automatically obtain addresses, it is setting up invalid IPs which aren't local. For instance, a valid local IP is while it is setting it up to

If I try to renew the IP when using Obtain Automatically I get the following error:

An error occured while renewing interface Local Area connection : unable to contact your DHCP server. Request has timed out.

The DHCP server is working well for all my collegues so it has something to do with my system. Maybe the DHCP client isn't working properly? However, this is enabled in the admin tools/services

Any ideas?

| improve this answer | |
  • 1
    The 169.254 part is done by APIPA (automatic private IP addressing) and basically means that the NIC got fed up waiting for a DHCPOFFER and made up its own address. You basic problem is that for some reason or another, DHCP packets aren't making it from client to server, or from server to client. – RainyRat Dec 4 '09 at 14:13

I would suggest that, after you've ruled out the physical reasons as Evan said, you run wireshark when plugging in your interface and monitor your DHCP messages to and from the server and see how far you are getting.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy