0

My friend has a tp-link tl-wr740n router. His PC has cable connection and it's ok all the time. Unfortunately, there is a problem with wifi connection. After restarting the router he can connect to the internet with his notebook and 2 smartphones but after several minutes wifi connection stops on all devices (except cable connected PC which is fine all the time). We tried to change wifi channel, mode, and channel width and updated the firmware but it didn't help. I thought that the router is broken but our another friend has exactly the same model. He brought it and we tested it but the result was exactly the same. What could be the problem? Should we provide more information?

  • You could try OpenWRT, as this FW seems to solve most of the problems with this router. – Tom Brek Aug 20 '14 at 11:26
  • Microwave, by any chance? Jokes aside, which hardware revision is it? What's his firmware version? – gronostaj Aug 20 '14 at 11:33
  • @gronostaj Hardware version is V4. We downloaded firmware from tp-link.com.pl/support/download/?model=TL-WR740N&version=V4 . It was TL-WR740N_V4_130513_PL before and we upgraded to TL-WR740N_V4_140626_PL. – kfinto Aug 20 '14 at 12:01
  • @TomBrek I don't have access to it right now, but we will try it later and let you know. – kfinto Aug 20 '14 at 12:03
  • Be careful with alternative firmware, it will void your warranty and may be buggy or break the router if something goes wrong. If you want to try it anyway, I'm using DD-WRT build 23919 on WR740N v4.21 since a month and it works well (but there are some known bugs, such as 5 GHz not working). It doesn't sound like a router issue to me, though. Borrow a completely different router and check if it works. – gronostaj Aug 20 '14 at 12:27
1

I had the same issue with this router TP link TL-WR740N / TL-WR740ND but I fixed it by upgrading to the latest firmware.

The link is http://www.tp-link.in/Support/download/?model=TL-WR740N&version=V4

Please check your hardware version of the router if you install and upgrade other version then the router will crash and wont work.

After this go to http://192.168.0.1 and use admin/admin as username/password

  • What firmware versions have the problem, and what firmware version are you recommending as the solution? "Latest" is a relative thing, especially if they put out a new firmware tomorrow that then reintroduces the original problem. – killermist Feb 7 '15 at 14:18
  • I have the same router with v2 hardware, upgrading the firmware didn't fix the problem. – DaneoShiga Feb 25 '15 at 12:11
0

Connect a network cable into the router. It doesn't have to be plugged into another device besides the router. This worked for me.

  • 2
    Do you mean just leaving an unconnected Ethernet cable dangling from the router solved your problem? I suspect that something else is going on. For example, moving the router and fiddling with the cables might have fixed a bad connection on another cable. – fixer1234 Feb 17 '15 at 0:26
  • Yes, unconnected cable, sounds stupid I know. I don't think moving the router or the cable did anything as I checked the LEDs beforehand, according to the LEDs everything was OK. Weird. – Florin Feb 17 '15 at 1:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.