0

On a ubuntu server I own, I am running out of space. When I ran

sudo parted /dev/sda -l

to find all available drives, I got this:

Model: ATA ST31000528AS (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system  Flags
 1      1049kB  256MB   255MB   primary   ext2         boot
 2      257MB   1000GB  1000GB  extended
 5      257MB   1000GB  1000GB  logical                lvm


Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/server--vg-swap_1: 2135MB
Sector size (logical/physical): 512B/512B
Partition Table: loop

Number  Start  End     Size    File system     Flags
 1      0.00B  2135MB  2135MB  linux-swap(v1)


Model: Linux device-mapper (linear) (dm)
Disk /dev/mapper/server--vg-root: 998GB
Sector size (logical/physical): 512B/512B
Partition Table: loop

Number  Start  End    Size   File system  Flags
 1      0.00B  998GB  998GB  ext4

I understand /dev/mapper/server--vg-root is the filesystem, and /dev/sda1 has some stuff related to GRUB.

But, what about /dev/sda2 and /dev/sda5? When I tried to mount /dev/sda2, it said that I needed to specify the file system, which according to the table, is nonexistent. So, is it safe to format this with, say ext4 and mount it?

Also, when I tried to mount /dev/sd5, it gave me this error:

mount: unknown filesystem type 'LVM2_member'

I assume it is NOT save to reformat this. If I'm wrong, then that would be great, because I could save some space. Please let me know either way. Thanks in advance!

UPDATE: Here is the result of mount:

/dev/mapper/server--vg-root on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
/dev/sda1 on /boot type ext2 (rw,acl)
/dev/sda1 on /media/hd2 type ext2 (rw)
2
  • This should either be on Linux/unix stack exchange or superuser. Aug 20, 2014 at 13:14
  • Apply some critical thinking skills, instead of wishful thinking skills. How big is your hard drive? How much data is stored on the computer now? Is it even remotely possible for there to be 1TB of unused space sitting around just waiting to be properly formatted?
    – Ben Voigt
    Aug 20, 2014 at 13:28

1 Answer 1

2

This is off-topic and will be migrated, but in the interest of preventing data loss I'm going to leave a short answer.

NO!

NO, do not reformat /dev/sda2! The extended partition is a container for logical partitions; doing anything to /dev/sda2 will cause the loss of /dev/sda5!

Notice the start and end sectors for /dev/sda2 and /dev/sda5 overlap. When you're doing something as dangerous as reformatting partitions, you should look closely at the information you're seeing...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy