I recently bought Logitech K750 Mac keyboard and it has that reversed functionality of FN keys, so you have to use FN key to make regular F1, F2 and other F keys to work.

We all know, that hid_apple is in in control of this behavior and running, the following made my FN keys work on on my MacBook Air laptop (with the same Fedora installation):

echo 2 > /sys/module/hid_apple/parameters/fnmode

However, this doesn't work with my desktop Fedora installation, with this new keyboard, that has Mac keys layout but not identifying itself as Mac keyboard. I even tried to add to kernel on boot:


and still no luck.

My suspicion goes to that I have to force Fedora identify this keyboard as being Mac. If I'm correct - how do I do it or what else am I missing here?


Solaar can be used for configuring Logitech Unifying receiver and newer Logitech products. Allows swapping fn-keys to act normally instead of as media buttons.


Found the information from this thread: https://askubuntu.com/questions/285512/how-to-change-function-fn-key-behavior-on-wireless-logitech-keyboard

| improve this answer | |

The solution happened to be completely unexpected and straight forward at the same time: Install Logitech SetPoint Software (on Windows or on Mac), go to My Keyboard -> F Key Settings.

There you will be able to find Swap F key functions - tick it and click apply.

enter image description here

The most important thing, that SetPoint writes and saves these settings directly on the hardware and as a result it works programmed way afterwards, even after reboot/shutdown and on all other systems.


If you turn off/on keyboard using switch on it, then settings will be reset to defaults but as there is no necessity for that, it's just fine.

| improve this answer | |
  • I'm using Ubuntu and I've found two things: 1) the behavior configured by SetPoint is hit and miss in Windows, as if it's reset on reboot, 2) when booting into Ubuntu my F12 always goes back to Sleep, so this solution does not work for me. Does this (still) actually work for you? I'd be interested, have been trying to find a solution for a while now, this seemed promising. – Sander Verhagen Sep 8 '19 at 3:58
  • 1
    @SanderVerhagen It was working, as far as I remember, if you don't turn your keyboard off. I switched now to Apple Magic Keyboard 2 (Bluetooth) and it's been just perfect. Logitech doesn't respect Linux users at all but Apple Magic Keyboard just works. – Ilia Rostovtsev Sep 8 '19 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.