5

I have UAC disabled because it is annoying and causes more problems that it could ever possibly solve, at least for me.

Here is yet another problem, and it seems to be due to a recent update as I don't remember it in the past.

Even with a MS account, I can't use the store because UAC is disabled. How can I get around this?

Short term I can just enable it, reboot, use store, disable it, reboot and be on my way but there has to be a better way (other than MS getting their software completely right - like that will happen anytime, ever)

Edit: Apparently this is far more of an issue than I originally thought. Now every(?)many metro apps requires UAC.

Anyone aware of the update this got rolled in with?

Thankfully netflix isn't affected which is the only metro app I use at the moment.

What I see: enter image description here

Event Log info:

Activation of app winstore_cw5n1h2txyewy!Windows.Store failed with error: This app can't be activated when UAC is disabled. See the Microsoft-Windows-TWinUI/Operational log for additional information.

  • UAC shouldn't be causing problems - programs that require elevated privileges should automatically ask for them (unless you're using pre-XP software). – gronostaj Aug 21 '14 at 20:16
  • this is not possible. – magicandre1981 Aug 22 '14 at 4:05
1

Someone from Microsoft who should know says Store Apps will not work with UAC off at around 4 minutes 20 seconds into this video .

This is with UAC set off in Group Policy or the Registry not setting the slider to Never Notify (which doesn't turn off UAC in WIndows 8)

  • 1
    This is my experience as well. Again, the fact that it's disabled through GPO or Registry rather than the control panel slider is crucial; the slider doesn't turn it off, it just stops notifying you about it. GPO/Registry is the only way to disable it completely. And once you do that, it causes problems with a number of Metro apps and Windows Store. But I don't use or want either, so I leave UAC off. – DarkMoon Aug 22 '14 at 2:38
  • Followup question: Is there any way around this? – Enigma Aug 22 '14 at 13:29
  • 1
    @Enigma No. I think it is tied up with the way Store Apps are sandboxes. – David Marshall Aug 22 '14 at 16:16
1

I am sitting at an 8.1 equipped, fully up-to-date box right now. I keep UAC off on this box for various reasons and have no issues running metro/modern-ui apps. I just successfully ran the hideous PDF viewer, music and store.

To my knowledge, metro apps cannot get admin privs so UAC is not required for them anyway so stopping them running with UAC off makes little sense.

I have seen issues with metro apps breaking with certain AV or browser changes, and with failed updates.

Are you certain the problem resolves when you turn the UAC slider back up? If so, when the apps fail to launch is there an error message or event log entry that may be helpful?

  • 1
    I updated with a picture. It has only recently become an issue and I currently cannot use Mail, Calendar or OneDrive and see the same pop-up. – Enigma Aug 21 '14 at 21:05
  • If you go to Administrative Tools in Control Panel and open Local Security Policy -> Local Policies -> Security Options and look down at the bottom at your UAC policies.... What is your "Run all administrators in Admin Approval Mode" set to? – Enigma Aug 21 '14 at 21:16
0

That helps for me:

SET HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLUA value to 1

  • 2
    Please explain how this answers the question. Altering random registry entries on the advice of strangers on the internet seems like a bad idea to me. – David Richerby Jun 17 '15 at 8:39
  • 2
    THIS ACTION ENABLES UAC AGAIN. – Joshua Jun 18 '15 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.