I have installed Ubuntu on VirtualBox on my MacBook Pro (running Mac OS X 10.5). I have set both Ubuntu terminal's text and my iTerm's text on MacBook using the same font (monospace) and same size (10).

My question is why the text on Ubuntu's terminal appear to be bigger and has more gap between lines? And why the ubuntu gnome environment has a 'low resolution' (I run on the same hardware), so I don't understand why the Mac OS X env appears to have higher resolution?

Thank you for any pointers.

  • I always have this problem with Ubuntu.
    – ayaz
    Feb 1 '10 at 20:04

You could try messing with the hinting settings in Appearance > Fonts > Details. The fonts look quite different when hinting is set to 'none' or 'slight' as opposed to 'medium' or 'full'.

Note that you may have a hard time getting the fonts to look just like on OS X (or Windows for that matter), simply due to the underlying font rendering system being different on Linux. This is my experience with this matter, in any case.


Problem A is because of problem B. So all you need to do is change the resolution in Ubuntu. You may have to install some proprietary graphic drivers. Do you know how to do that in Ubuntu? It's pretty easy to figure out, within the 'Admin' menu, but otherwise it's an easy google search.


The first place to check is whether your DPi is set lower.

Within Ubuntu/Gnome, go to Appearance > Fonts > Details

At the top is a Resolution option, I believe by default this is set to 96 DPI. If this value is different it will cause your fonts to appear larger/smaller than you expect.

  • I have checked. The Ubuntu setting is 96 DPI. And I think the MacOSX setting is also 96 DPI. ~ $ xdpyinfo | grep -i resolution resolution: 96x96 dots per inch ~ $
    – hap497
    Dec 8 '09 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.