In another words, how to make fonts get smaller than the default on native LCD resolution?


Windows 7 itself won't let you do that, directly. Here are the options you get:

Windows 7 "Custom DPI Setting" dialog

You can find that by choosing Control Panel > Appearance and Personalization > Display and then clicking the "Set custom text size (DPI)" link in the left panel.

You can actually get numbers other than those shown by dragging the ruler, but it won't let you select something smaller than 100% ... nor can you type in something smaller than 100%; it won't take. 500% seems to be the upper limit.

Microsoft has a good article describing this feature: Make the text on your screen larger or smaller.

So ... if what you're asking can be done at all, it would likely be through some kind of hack. If I find one, I'll come back and update this. But, officially I think the answer is "you can't do that."

UPDATE: OK, there is a registry hack. I found details here:
Save your eyes with DPI Scaling in Windows Vista (Post 8 of 24)

Quoting techrepublic.com user MetaPop here:

Use at your own risk, the side effects are not known.

1. Be careful:
Create a restore point.
Export registry to a file to save it.

2. Edit Registry:
Navigate to HKEY_CURRENT_CONFIG, Software, Fonts
Name=LogPixels value is 96 decimal.
For 90 percent font size, set to 86 decimal.
For 80 percent font size, set to 76 decimal.

Close REGEDIT and reboot the computer.

3. If some text appears too small or blurry try different value or
return to 96 dpi.

If that does not work or partially (just at the log-in screen) then you may also have to make the change at the registry location: HKEY_CURRENT_USER\Control Panel\Desktop, Name=LogPixels. follow steps above (tested in Windows7 SP1).

  • Same I figured out. Anyone can tell why MS did it in that way? – Maniero Dec 8 '09 at 0:42
  • MS probably restricted it likely because settings less than 100% may break text rendering in some software. BTW, note the update above; there is a way, and it is a hack. Be careful, YMMV. – Chris W. Rea Dec 8 '09 at 0:53
  • 2
    I've learned there are some aplications that don't handle it too well. Namely fullscreen games often the mouse will stop working for the bottom and right 205 of your screen if you are set to 80%. Also Aero Snapping has a lot of issues as well. I know this is an old post but this site is usually about collaboration so I hope no one minds me adding this. – Sean Jan 22 '14 at 7:08
  • 2
    Rebooting isn't necessary to make the change effective; it's sufficient to log off and log in again. – gm2 Apr 3 '14 at 19:39
  • 3
    Not working in Windows 10? tried both methods – laggingreflex Apr 5 '16 at 15:53

protected by BinaryMisfit Dec 22 '10 at 14:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.