28

While installing Cisco AnyConnect 3.1.05170, the following error message appears in a dialog box.

Cisco AnyConnect Secure Mobility Client

The VPN client agent was unable to create the interprocess communication depot

How do I fix this?

36

Here are the steps to resolve the problem:

  1. Press Win + R
  2. Type: services.msc and press Enter
  3. Find Internet Connection Sharing (ICS)
  4. Stop the service
  5. Right-click and open the service's Properties
  6. Change the Startup type: to Disabled
  7. Reboot the computer
  8. Install Cisco AnyConnect VPN
  • This worked for me on Windows 10. I think it should be the accepted answer for that operating system. – Startec Sep 8 '16 at 8:41
  • What if the ICS is already deactivated? – basseur Jun 11 '18 at 13:57
  • what if this error is on ubuntu? – jvdh Apr 10 at 11:50
19

To resolve this issue on Windows 7:

  1. Click the Windows Start button.
  2. Click on Control Panel.
  3. Set View by: to Category.
  4. Click on View network status and tasks under Network and Internet.
  5. Click on Change adapter settings.
  6. Look for Shared in the Status column in the Network Connections window and right-click that device (e.g. Ethernet adapter, WiFi adapter) and click Properties.
  7. Click the Sharing tab.
  8. Clear the Allow other network users to connect through this computer’s Internet connection check box.
  9. Click OK.
  10. Reinstall Cisco AnyConnect.

These instructions may not be accurate for other versions of Windows besides 7.

  • 3
    WOW! This was the weirdest reason & this solution actually worked! Thanks. I was struggling for a long time around it.. :-) – anishsane Dec 31 '14 at 9:50
  • I don't understand what I'm supposed to do in step 6, where's the status column and what connection should this be? Network sharing is currently enabled on my Wi-Fi adapter, and there is no real ethernet adapter (MacBook Air running Windows 8.1). – CoDEmanX May 22 '15 at 13:52
  • 1
    Yeah thanks, I just had to change the sharing settings for the active adapter (which was the physical Wi-Fi adapter in my case). Fixed the issue! – CoDEmanX May 23 '15 at 17:09
  • Check all your adapters, even the disconnected and disabled ones. I have an OpenVPN connection that I'm legitimately sharing (due to a Windows-only HSM) that prevented me from installing AnyConnect. – andyn Feb 15 '17 at 14:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.