1

I have a MSI FR720 laptop with Windows 7 and Lubuntu partions.

For quite a while (6 months or so) I've been having issues booting from my hard drive, it'd take me between 5 minutes and several hours for me to be able to have it recognize the hard drive as a bootable device. I did several disk checks on it, and my hard drive seems in perfect condition, and the fact that booting would usually only work after removing the hard drive and trying to reset it in its slot or lightly shaking it makes me think it had something to do with the connection in the hard drive slot as opposed to the hard drive itself.

I was having particular issues with it detecting the hard drive today so I decided to try booting it from an external hard drive dock. It detected it first try and so far has had no problems finding the bootable partitions on my hard drive.

When I selected my Windows 7 partition from the boot menu it said that it hadn't been shut down properly last time and needed startup repair. I've done this several times over the last 6 months, so this is hardly unusual. I do startup repair, it fails, and then I try to do a system restore. The system restore also failed, and it says that no files were changed. I restart and try it again.

However, this time when I get to the startup repair it's not detecting a Windows OS. I tried clicking next and doing a startup repair but the repair is always failing. If I ignore the startup repair option and instead select "Launch windows normally" it will get to the windows animation, stop halfway through and then crash into a BSoD. I can't read the error on the screen because it immediately switches to back and tries to restart.

This is my first time asking a question like this online, so let me know if I need to provide any extra information and I'll do my best to give it

I tried using diskpart to find the list of partitions and see if one's labelled as an active partition, but it says that no disk were detected.

I can run Lubuntu just fine. I can also see all of my Windows 7 files from it

EDIT: The startup repair diagnosis and repair log is this:

--

Number of repair attempts: 1

Session details System Disk = Windows directory = AutoChk Run = 0 Number of root causes = 1

Test Performed: Name: Check for updates Result: Completed successfully. Error code = 0x0 Time taken = 15ms

Test Performed: Name: System disk test Result: Completed successfully. Error code = 0x0 Time taken = 31ms

Root cause found. If a hard disk is installed, it is not responding.

--

Any chance that this is a result of me doing this through an external dock through a USB drive?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.