2

I'm using Windows 7 x64 Ultimate. I have an existing 4TB disk with 3 NTFS volumes, a new 3TB blank disk, and I'm trying to mirror the volumes onto the new disk.

My Windows install is on an SSD which is Disk 0. The 4TB disk with volumes is Disk 1, and the new blank disk is Disk 2.

Problem: I can add a mirror successfully for the last volume on the disk, but when I try to add a mirror for the first volume on the disk I immediately get errors (see below).

Is there something I special I need to do to add a mirror for a volume other than the last one on a disk?

More info:

I opened Disk Management, right-clicked on the first volume on the existing disk, went to Add Mirror, and selected the new disk. The first time I did this I was prompted to convert the new disk to a Dynamic Disk, which I approved. Subsequently I got a message:

The operation failed to complete because the Disk Management console view is not up-to-date. Refresh the view by using the refresh task. If the problem persists close the Disk Management console, then restart Disk Management or restart the computer.

I've refreshed disk management, restarted the computer, and converted the new disk to basic and back to dynamic, but I still get that error message.

Looking around for suggestions of a workaround, I saw a suggestion to use the diskpart command line tool.

Running diskpart from the Start Menu as Administrator, I did select volume 2 (the first volume I want to mirror) and then add disk 2 (the new disk), and received a somewhat similar error:

Virtual Disk Service error:
The disk's extent information is corrupted.


DiskPart has referenced an object which is not up-to-date.
Refresh the object by using the RESCAN command.
If the problem persists exit DiskPart, then restart DiskPart or restart the
computer.

A rescan appears to be successful:

DISKPART> select disk 2

Disk 2 is now the selected disk.

DISKPART> rescan

Please wait while DiskPart scans your configuration...

DiskPart has finished scanning your configuration.

but attempting to add the mirror again resulted in the same error.

The only similar report I found online was this:

http://www.sevenforums.com/hardware-devices/335780-unable-mirror-all-but-last-partition-drive.html

Based on that I attempted to mirror the last volume on the disk to the new disk using diskpart, and that started successfully -- it is currently resynchronizing.

More Background:

In the course of dealing with a failing 3TB hard drive, I bought a replacement 4TB drive and installed it, then copied the partitions from the failing drive to it using Minitool Partition Wizard Home, and then removed the failing drive and was up and running again normally.

Now I've received a warranty replacement for the failing drive, and installed it, and now I'm attempting to mirror my partitions to it.

1

Had a similar problem with not being able to mirror my 3GB drive, tried reboots etc. The main volume was ~3TB, with 50MB of unallocated space for safety. Finally got the problem to go away by extending the main volume by 1MB. Seems like some sort of Windows bug that got cleared by doing the extend.

(I intentionally leave a bit of space at the end because I've had the situation where the second disk was ever so slightly smaller than the first, and Windows would not allow me to mirror without rebuilding the volume.)

0

Similar answer as Joel, except that I had to shrink then extend. I had 4 volumes on my disk, so I shrunk them by 1024 MB then extended by 1023 MB. Then I was able to Add Mirror successfully.

  • Each answer should contribute another solution. For minor tweaks to another answer, or to share information on a slight variation you employed, it might be more appropriate to do that in a comment. – fixer1234 Jan 4 '16 at 7:18
  • Thanks for the suggestion, slight variation would be the key phrase. I'm not sure how common it is for people to configure their drives as Joel does with unallocated space at the end. Shrinking and then extending by a number smaller than the original shrink was also required. Using the same number as the original shrink didn't work. I'd have thought just shrinking, any change, would have worked given Joel's answer. But it required both in my case. I guess I consider that above slight and not something anyone would intuitively try.... – k3yz101 Jan 5 '16 at 8:15
-1

Just to let people know, I don't have space at the end of my drive, and I shrank it by 4096 bytes, and then expanded it again, and it worked fine

WD 2TB Green Drives

(If I could I'd delete this and add a comment, but apparantly I need rep to add comments, so it'll have to stay as an answer)

Please don't vote for it.

  • Your lack of reputation to submit a comment is immaterial. You should still NEVER submit a comment as an answer. This is nothing more then a slight alternation to the answer by k3yz101. Shrinking a partition is not the simplest process, and since you provided no specifics on how you acomplished that, people with the same problem as the author won't be able to implement your solution by themselfs. – Ramhound Jan 19 '17 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.