0

So I have been searching the web for days, looking for a solution to my problem.

Now my only hope are you guys.

I have installed Owncloud successfully on my Windows Server 2008R2. It all runs smoothly and I can connect without problems.

So first checks are OK. Now I wanted to change the default data directory from my server to a shared folder on my NAS (Synology DS1813+, DSM 5.0-4493 Update 3).

Tried following: changing the directory in config.php I changed the path in the config file from : "C:\inetpub\wwwroot\myfolder\data" to "\NASIP\cloud". by doing this the owncloud server only shows:

Code: Select all
    Daten-Verzeichnis (\192.168.2.4\Cloud\data) ist ungültig

    Bitte stelle sicher, dass das Daten-Verzeichnis eine Datei namens ".ocdata" im Wurzelverzeichnis enthält.

I also tried coping the files that were created in the local data storage, to the share on the NAS. No Luck.

Now I tried it by mapping a network drive and using that in the config.php But still no luck. I get the same message with the missing .ocdata file.

Now I tried the "External Storage APP" that comes with owncloud I thought that at least I could add the share as an external storage. But this also does not work. tried UNC, Mapped Drive Name (Z:) but nothing helped.

So now I'm turning to you.. Does anyone have expirience with this kind of setup? Or can you even tell me how to make it work? (default or external storgae, I don't care anymore )

Using NAS (Synology DS1813+, DSM 5.0-4493 Update 3), Owncloud 7, Windows Server 2008 R2, IIS7

I got an answer on an other forum:

The second option is how it should be done: 1. Put OC in maintenance mode 2. Mount (mapping in the windows world) your NAS directly to your OS 3. Copy the local data directory to the NAS mount 4. Ensure the permission is setup to give the web user access to the NAS mount 5. Update OC config.php with the new data path 6. Disable OC maintenance mode

And this seems like the right way..

Ensure the permission is setup to give the web user access to the NAS mount

I guess this is where I am not sure.

  1. What user is it exactly on my Server that is making the requests to the NAS?

  2. If the user is for example "IUSR" I can just create an account on my synology NAS and give him full access to my share? (But what is IUSRs password?)

  3. I have full root ssh access to my NAS, so if you can tell me what chmod or chown I need to use on my cloud folder...

1

I did it !

The solution was to configure an iSCSI Target and LUN with my synology NAS. After that, all I had to do is connect to the LUN from my Server and change the datadirectory to the newly added iSCSI LUN.

tada .. everythig works = )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.