I've moved a drive containing Win7 64bit to a different computer. The architecture is not too different. The "new" computer (not too new, really) is an AMD FX 4100 quad core, GeForce GTX 560, some random cheap old motherboard. The original computer was an even older AMD CPU (quad core), older GeForce, etc. Everything is 64 bit.

When the new computer boots up, it bluescreens very briefly (the image below is basically just one frame from a video), then immediately resets.

enter image description here

Next time it comes up, it gives me the option to repair itself, I've tried it, but that doesn't help.

I've tried booting into safe mode, but it resets even there. However, the repair option goes into something like safe mode while doing repairs, and that one works fine.

I've tried going into the BIOS and disabling the onboard sound card, the onboard network port - no luck.

I really don't want to reinstall this computer. What is the most likely cause for the bluescreen, that I could fix without reinstall?

  • possible duplicate of Moving a PC from one hard drive to another? – Hennes Aug 25 '14 at 7:09
  • @OP: Move the disk back to the original PC. Make sure you have a full system backup on an external disk (or other location). Uninstall potential troublesome programs (e.g. wireless card drivers with helpful programs). Run sysprep and shut down. Move the disk to the new PC and boot it in its clean, sysprepped state. It should now work. – Hennes Aug 25 '14 at 7:11
  • 1
    Code 0x7B corresponds to INACCESSIBLE_BOOT_DEVICE. – and31415 Aug 25 '14 at 11:01
up vote 4 down vote accepted

As and31415 pointed out, a 7B stop error corresponds to an inaccessible boot device. This is usually due to a change in SATA mode, such as moving from RAID to AHCI or AHCI to Legacy. It can also correspond to a change between controllers, such as from an Intel storage controller to an AMD storage controller.

See the Microsoft KB here.

  • In the BIOS, I've changed Chipset / Southbridge / SB SATA configuration / OnChip SATA type, from AHCI to Native IDE, and now the computer is booting up just fine. – Florin Andrei Aug 31 '14 at 5:21

There's likely to be enough differences between your new motherboard, processor, CPU and graphics card to cause this sort of problem. If you have the Windows 7 install media (eg. Windows 7 Ultimate with SP1 etc) you could boot from that and do a repair install, you'll lose a few settings but it's got a reasonable chance of success. Bear in mind it will take a few hours to perform the repair as it will try and copy your existing settings etc as part of the process and rename your original Windows installation folder.

A very good guide is located here: Windows 7 Repair Install and while it's an 'install' you are less likely to need to reinstall all your apps than if you did did a reinstall.

I followed WinOutreach2's link and found the instructions very useful. I couldn't boot into the system but was able to use WinPE to load the regedit make changes to both ControlSets.

Locate and then click one of the following registry subkeys under both ControlSets:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV

In the pane on the right side, right-click Start in the Name column, and then click Modify. In the Value data box, type 0, and then click OK. On the File menu, click Exit to close Registry Editor.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.