17

OS: Windows 7 x64

VirtualBox: 4.3.14 & 4.3.15

CPU: i5-3570

Motherboard: Gigabyte GA-H77M-D3H

I receive the error below when I try to run a virtual machine with Enable VT-x/AMD-V on. With this setting off the virtual machine runs successfully.

Failed to open a session for the virtual machine
MachineName

VT-x is being used by another hypervisor.
(VERR_VMX_IN_VMX_ROOT_MODE).

Virtualbox can't operate in vmx root mode. Please close all other virtualization programs.
(VERR_VMX_IN_VMX_ROOT_MODE).

I have the virtulization settings set to on in BIOS.

I tried updating BIOS, it didn't fix the problem.

When my BIOS was updated virtulization was off by default, and going into VirtualBox the Enable VT-x/AMD-V option wasn't there, I turned virtulization back on and the option was back - so VirtualBox appears to correctly know when my virtulization is on.

I tried updating VirtualBox from 4.3.14 to 4.3.15 as apparently it fixes some problems with anti-virus programs intefering with VirtualBox, so I updated to rule that out, still the same problem.

I have no other virtulisation software installed as far as I know.

As far as I know I don't have any programs running in compatibility mode.

Any ideas what else could be causing this error? Or is there any way to find out what else is using VT-x?

  • some malware or even some antivirus can install itself as hypervisor. May be the case? – pqnet Aug 25 '14 at 13:25
40

It's happened to me when I was using a Android Virtual Device. Check if you are using other virtual machine at the same time.

Hope this help.

  • This is not an answer to the original question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – DavidPostill Feb 14 '15 at 6:46
  • 2
    @DavidPostill actually the issue can come from running multiple virtualization hosts on the same CPU at the same time. I've submitted an edit to clarify this. – zymhan Mar 24 '16 at 15:05
  • What should I do if I need Virtualbox machine and Android Virtual Device running at the same time? – Vadim Kotov Mar 27 '18 at 13:47
  • @DavidPostill this is actually a solution. I just turned off an Android Virtual Device I had running, and the Vagrant machine started without problems. – xarlymg89 Jul 19 '18 at 12:32
1

If you have Microsoft Virtual PC installed, or its replacement Hyper-V, you need to uninstall it. Either of these will cause the problem you are seeing.

You may also need to uninstall any other virtualization programs you may have downloaded, such as VMware Player/Workstation.

1

I fixed the problem by uninstalling and installing 4.3.12 instead. Looks like it's a bug in 4.3.14 & 4.3.15 and I've reported it now.

  • I use 4.3.24 and have same problem. – e-info128 May 26 '15 at 17:00
  • You should really link to your bug reports for future reference, so that we can know if this particular issue was fixed, or even if the issue applies to our specific situation. – zymhan Mar 24 '16 at 15:06
0

I had the same issue a while back. I've updated to a newer version of virtualbox, and a previously working VM spew this error on new version. I checked for solutions online and asserted that no other process using VT-x. Set virtualbox.exe to run elevated (aka as administrator), no change.

Then I realised that I ran the installer non-elevated. Oh that might be it. Uninstall, then re-install elevated. Issue gone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.