0

I am trying to install Flash player 14 ActiveX plug-in for Windows 7 in Windows 8.1.

You might say Windows 8. 1 already has it but I have a program which specifically needs the ActiveX plug-in for Windows 7 from the Adobe website.

It was fine until some days ago I could install Flash Player very correctly but now I get this error when installing flash player "FAILED TO REGISTER" every time and it's driving me nuts. I need to install Flash Player so my program can use it.

I'm installing this install_flashplayer14x32ax_mssd_aaa_aih

And I also tried this solution on the Microsoft website using subinacl and reset_fp11 but it doesn't seem to work,

  1. Uninstall (clean) any of your adobe flash player files. See the instruction and file to download: http://kb2.adobe.com/cps/141/tn_14157.html
  2. Reboot your computer.
  3. You must have administrator privileges to successfully complete these instructions.

Warning! The following solution involves the Windows System Registry. Editing or manipulating the registry incorrectly can result in serious system damage which may require reinstallation of the operating system.

  1. Follow the instructions to download the SubInACL tool from the Microsoft Download Center. http://www.microsoft.com/downloads/details.aspx?FamilyID=e8ba3e56-d8fe-4a91-93cf-ed6985e3927b&displaylang=en
  2. Download SubInACL in a folder of your choice.
  3. Download the reset_fp10.zip file. http://kb2.adobe.com/cps/494/cpsid_49419.html
  4. Important: Be sure that both the subinacl.msi and reset_fp10.cmd files are in the same location (folder).
  5. Double-click reset_fp10.cmd.
  6. This will open a command window and execute the SubInACL tool.
  7. Do not use the machine while SubInACL is running.
  8. When it is finished you will see "Press any key to continue".
  9. Install the Flash Player from www.adobe.com/go/getflashplayer.

Does anyone have any other solutions to this?

  • Umm.. wait i have google chrome so will this unistaller remove flash of google chrome also. Also i already tried the 2nd method but the bat file is diffrent testing now. – bijay135 Aug 26 '14 at 12:34
  • No no I did all of the above steps 2nd time it's still giving me same error "Failed to register " -______- It's really pissing me off now. – bijay135 Aug 26 '14 at 13:04
  • Please be aware, installing flash player is a bad idea all around due to how insecure and exploitable it is. All Chromium based browsers have a patched version of flash player built-in, so there should be no reason to have the standalone version installed. What program are you using that requires it? – JW0914 Sep 15 '19 at 14:29
0

The following from See https://forums.adobe.com/thread/910774 worked for me. Though I just deleted the two directories he named.

  1. Permissions must be set manually on C:\Windows\System32\Macromed\Flash ( as Administrator -- right click on folder's name then launch Properties, switch SECURITY section and select your user. REMEMBER: your account must be administrator rights. check under Allow boxes there, then Apply all changes)

  2. Same process must be done also for C:\Windows\SysWOW64\Macromed\Flash

  3. Download latest http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp_11.1.102.55_archive .zip it s an installer archive.

  4. try to install fp_11.1.102.55_archive\11_1r102_55_64bit\flashplayer11_1r102_55_winax_64bit.msi do not try to install exe versions. it doesn't work. MSI installer worked for me...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.