8

I'm currently getting Google Now notifications on my Android phone, my OSX laptop, and my Windows 8.1. Sometimes these notifications are great, but most of the time it just shows me the weather. The weather notifications almost always come at inopportune times (the last two were right after I got to work, and at 3 AM), and are never helpful.

How can I disable the weather notifications without disabling the other notifications?

11

Go into the Google Now app and tap the three dots in the top-right corner of one of the weather cards. You'll get a pop-up that reads "Interested in weather updates for your location?" Tap "NO" and that should be it.

If that doesn't do it, go into the Google Calendar app, open the menu, and select "Calendars to Display." If the local weather is included in that list, uncheck the box next to it.

enter image description here

  • I checked my calendars, and don't have any sort of weather calendar. The weather cards that I receive and typically smaller, and don't include the forecast. I'm fairly certain I tried clicking the menu icon in the top right in Android before, and it didn't provide any sort of option to turn it off. I've gotten two weather notifications since asking this question, but they've both been in OSX, and has an X instead of the menu button. – Brian Aug 27 '14 at 20:13
  • Do you have Google Chrome installed on the OSX and Windows devices? – P Fitz Aug 28 '14 at 18:02
  • Yes, Chrome is installed on all three devices. I don't think I would be getting the notifications if it wasn't. – Brian Aug 28 '14 at 19:13
  • The weather forecast card popped up on my Android device this time, and your instructions worked. Thanks! – Brian Aug 29 '14 at 17:35
  • 5
    Note: this will disable the weather card in Google Now, not just the notifications. – Andrew McKinlay Jun 1 '15 at 20:00
2

On Android I finally figured out how to only disable the weather notification, without removing the weather card or disabling notifications in general.

  • Open Google Now
  • Open Menu (swipe from left or press ) / Open Settings
  • Open Now Cards and scroll down to Get Notifications for sections
  • Uncheck Weather or Sport or whatever you don't want to get notified about

You will still see the card in Google Now, but the notification is gone. Exactly what I wanted to achieve.

  • Swiping from the left doesn't do anything for me in Google Now, and I don't know what you mean by "Burger Button". – Brian Aug 23 '16 at 18:44
  • @Brian the burger menu button, for me it's on the top left corner (marshmallow). Some android devices have a hardware menu button and don't show the icon. But I an taking about the default google now menu, one way or another you can open the settings. – Jürgen Steinblock Aug 23 '16 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.