0

My acer aspire r7 won't charge and it states "plugged in, not charging." Looks like this is a fairly common problem people are having. I have tried many suggested solutions that I I found researching and nothing has worked yet.

There is the "12 step" solution which seems promising:

  1. Disconnect AC adapter
  2. Shutdown Windows 8
  3. Remove battery
  4. Connect AC Adapter
  5. Power on the laptop
  6. Open the Control Panel and select Device Manager
  7. Under the Batteries category, right-click all instances of Microsoft ACPI Compliant Control Method Battery , and select Uninstall, even if you have only one (I had two, as shown in figure 1 below)
  8. Shutdown
  9. Disconnect AC adapter
  10. Insert battery
  11. Connect AC adapter
  12. Power on the laptop

The problem for me with this solution is step 3 which requires you to remove battery and my laptop has an internal battery. I tried doing all the other steps and no luck. Any suggestions would be very much appreciated. Thanks so much, Abbi

  • There should be an option in the BIOS to disable internal battery. – Michael Frank Aug 26 '14 at 3:50
  • Have you tried starting at step 6? – Jens Ehrich Dec 10 '16 at 23:11
  • At what percentage of battery level does it show this? Mine usually shows it when the battery is fully charged and then stops charging until the battery drops to a certain level then it starts charging again. – Ahmed Akhtar Sep 27 '18 at 6:01
-1

It's possible that the pin in the charging port could be broken or simply not receiving electricity. Don't be afraid to take a screwdriver to your computer but take precautions.

  • An acer aspire r7 charger appears to have a 2-pin charger. If it detects the charger at all then it's most likely not a connection issue. – Jens Ehrich Dec 10 '16 at 23:10
-1

Try to

  • discharge your battery completely in BIOS (because most OS will shutdown on critical battery level).
  • Then remove battery, unplug cable and push your power button for a few seconds to get all voltage out.
  • Plug in your cable and hold power button 30 seconds.
  • Put in battery and look if it works now

protected by JakeGould Sep 27 '18 at 2:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.