4

I have a few hundred messages that are all mostly identical. Each message has one of the following strings in the message body.

foo:1 (bar)
foo:2 (bar)

I would like to find all messages with the first string, but not the second.

I have tried everything I can think of in both the quick and advanced search functions in Outlook 2010. In particular, all of the following search terms return messages with foo:2 (bar).

"foo:1 (bar)"
"foo:1"
"foo:1 "
"1 (bar)"
"1 "
"foo\:1"
"1 \(bar\)"

Here's an example screenshot showing what I'm talking about:

enter image description here

The two messages that are found both have message bodies corresponding to their subject lines.

How can I find these messages using Outlook search?

2
  • your screenshot shows Message not Subject ... consider showing us what the messages are, not what the subjects are. Mar 25 at 21:44
  • @undrline-ReinstateMonica This question is seven years old. I'm no longer using Outlook 2010, I don't have access to this mailbox anymore, and I solved my problem manually seven years ago. But, as I said in the question, the bodies of the messages were the same as the subjects for the two sample messages. But my entire inbox was found as well, and I definitely did not have foo:1 (bar) in every inbox message. Mar 26 at 12:36
1

You must use Advanced Find (CTRL+SHIFT+F), using the Advanced Tab (pictured below), to search for special characters. Instant Search ignores special characters.

Advanced Find Advanced Tab

5
  • I mentioned in my question that I have tried using both instant and advanced search functions. Neither works. Aug 26 '14 at 13:16
  • The title makes the question sound like a "how to search for special characters" type question. It sounds like you're looking for messages that include A but not B. Assuming these values are known/constant, why not use Advanced Find's Condition field in the Advanced tab and search where "Contains='foo:1 (bar)'" and "Doesn't Contain='foo:2 (bar)'" ?
    – root
    Aug 26 '14 at 13:24
  • I am doing exactly that. Advanced Find is still coming back with messages that contain foo:2 (bar). Aug 26 '14 at 13:36
  • 1
    If you don't believe me, here's a screenshot. Each message has a body with the corresponding subject in it, but you can see both are coming back in the search. More than that, everything in my Inbox is coming back. I assure you they don't ALL contain foo:1 (bar). Aug 26 '14 at 13:53
  • @KrisHarper your screenshot shows Message not Subject ... consider showing us what the messages are. Mar 11 at 18:47
1

[using Microsoft Outlook for Microsoft 365 Enterprise at my company, Version 2008 (Build 13127.21348)]

Trythe following:

  1. Within Outlook, select Search > Search Tools > Advanced Find
  2. In the Appointments and Meetings tab Search for the word(s): field enter the word (including special characters) you are trying to find (e.g. Training:)
  3. In the More Choices tab, select the Match case checkbox
  4. Click the Find now button

This gave me the results I wanted. I was looking only for "training" events I had completed where I put "Training:" in the Subject. Using the Match case checkbox forced the search to include the colon.

Hope this helps!

0

Try using

~="foo:1"

It's not obvious, but if you use quotes you can also precede them with a comparison operator. This comparison operator with the tilde means 'has this substring'.

You can also use more normal comparisons, like <, but they are not generally very useful.

-1

Outlook search doesn't work, apparently, so I went through every message manually and categorized them by sight.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.