I am running boot2docker on windows and I am trying to access a shared folder on my host from the VM.

I have executed the following

  sudo mkdir /mnt/docktest
  sudo mount -t cifs // /mnt/docktest -o user=username
     mount: mounting // on /mnt/docktest/ failed: Permission denied
  sudo mount -t smbfs // /mnt/docktest -o username=username
     mount: mounting // on /mnt/docktest/ failed: No such device

My host ( has the folder "dock" shared with access to the user I am supplying.

I have tried adding the password and domain in the command as well to no avail (even though I would rather not have to)

Note: I would rather not share the folder using the VirtualBox shared folders as it would restrict me to be between the host and it's own vm.

1 Answer 1


the solution was to install cifs-utils using tce-load

  • Exactly how did you do this? When I run tce-load -wi cifs-utils at the boot2docker prompt, I get wget: server returned error: HTTP/1.1 404 Not Found.
    – Ben
    Aug 30, 2014 at 20:52
  • I first used wget to download the file (found a download link online) then installed it locally using tce-load -i <filename> Sep 1, 2014 at 8:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.