0

I tried upgrading my mom's PC to Windows 8.1 and it wen't smooth for the most part except I could not connect to the wireless network anymore. The driver for the wireless adapter was installed (tried both microsoft's and TP-Link's) and networks were appearing, it just wouldn't connect. Took me awhile to figure out it wasn't connecting to the wireless n network, but would connect to g or b standard networks. The wifi adapter is supposed to be compatible with Windows 8 so I'm not sure why after the upgrade I'm unable to connect to the n standard network.

Wireless Adapter: TP-LINK TL-WN951N Wireless N300 Advanced PCI Adapter

Wireless Router: TP-LINK TL-WR941ND Wireless N300 Home Router

Router Firmware: DD-WRT v24-sp2 (03/25/13) std - build 21061

  • We'll need more information about your network setup. What authentication and encryption settings is the WiFi setup to use (at the router)? What have you tried? Windows 8+ doesn't like WEP. – Ƭᴇcʜιᴇ007 Aug 26 '14 at 17:22
  • Are you unplugging your LAN when you try to connect via wifi? – jAce Aug 26 '14 at 17:29
  • I am using WPA2 Personal for security and that PC is never connected to LAN. – Shawn Aug 26 '14 at 21:23
  • Have you tried shutting security off just for a test? If that would fix it then test out the different security protocols. – jAce Sep 10 '14 at 17:45
0

Are you sure it's not n? Check this at the command prompt.

> netsh wlan show interfaces

If it is not already 802.11n then check the wifi properties: http://www.thewindowsclub.com/enable-802-11n-mode-wireless-connection-windows-8

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.