5

I am lucky to have a screen with BGR subpixel layout.

With lucky I mean that Google Chrome 37 now forced RGB subpixel rendering with their recently added DirectWrite text rendering method. Text is exhausting to read now.

Does anyone know how to force a BGR subpixel layout?

  • Did you run the ClearType optimizer thingy yet? It’s supposed to support BGR, although I don’t know if affects DirectWrite. – Daniel B Aug 27 '14 at 16:37
  • It changes the system settings, yeah. But Chrome completely ignores this when initializing DirectWrite, which is unchained with the system settings. – Ray Koopa Aug 27 '14 at 17:07
6

For now, there are two workarounds, but no real possibility to set the subpixel rendering to BGR.

Go to chrome://flags and set the flags stated below to the specified values.

  1. Disable DirectWrite completely and use the old GDI drawing methods.
    You can completely disable the new rendering method and use the old one as in pre-36.
    Disable DirectWrite: set it to Enable

  2. Use grayscale subpixel rendering instead of red and blue
    Keep using DirectWrite, but subpixeling will not use red and blue, but grayscale colors instead.
    LCD text antialiasing: set it to Disabled

Restart Chrome and you will see the changes.

EDIT: A recent comment around my bug reports says it will be fixed in the upcoming Chrome versions.

  • Thanks so much for the workaround! I wish Chrome updates would come with a heads-up notification for situations like this: "This is why your fonts may suddenly look strange, and how to revert the change if needed..." – acatalept Aug 28 '14 at 20:26
  • 1
    Well I'd be happy if they'd just respect BGR subpixel rendering. This is a bug if you ask me. Adobe Reader does the same error. – Ray Koopa Aug 28 '14 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.