I tried to move my mysql data dir from one disk to another, I modified the datadir parameter in my.cnf, but when XAMPP, and more precisely, MySQL starts, this error is displayed and MySQL doesn't run.

Operation could not be completed.  
(XAMPPErrorDomain error 1.)  

What's the problem here? I correctly specified the new path.


Look in your logs: apache friends - xampp for linux faq >> Error 1

  • Thanks, although my error log says nothing about it. Mine is in "Applications/XAMPP/xamppfiles/logs/error_log" – Petruza Dec 8 '09 at 22:31
  • Try the mysql logs; they may be in different places. (MySQL docs say they're not available in Console.) See serverfault.com/questions/42531/where-is-my-mysql-log-on-os-x And last resort, check that link above for an email for help with that error. – markratledge Dec 9 '09 at 4:49
  • Thanks, in the end I realized looking at the logs, that mysqld was not using the datadir from my.cnf but instead was following a symbolic link in '/Applications/XAMPP/xamppfiles/var/mysql' pointing to the old data dir. Changed that and it worked, of course. Thanks! – Petruza Dec 9 '09 at 14:14
  • Petruza, any more information or details on what you needed to do to clear this error? – Alan H. Feb 13 '11 at 21:49

I also have this problem but none of them works, I compared with files one by one on new machine and the old ones finally find the this works for me:

sudo chown -R nobody:admin /Applications/XAMPP/xamppfiles/var/

Same error. Easily resolved on Mac OSX by changing permissions of the Xampp folder in applications to allow read&write access !

  • Especially if you just copied back a backup from another machine. Worked for me, too. – Kai Mattern Jan 29 '13 at 12:20

I found a tip elsewhere that says to run:

> sudo ${XAMPP_HOME}/xamppfiles/bin/mysql.server start

I did, and the result was interesting:

> sudo ${XAMPP_HOME}/xamppfiles/bin/mysql.server start
sudo: /xamppfiles/bin/mysql.server: command not found

Thus ${XAMPP_HOME} is undefined.

So I edited ~/.bash_profile and added the line:

export XAMPP_HOME="/Applications/XAMPP"

After restarting Terminal, our command now yields:

Starting MySQL
. ERROR! Manager of pid-file quit without updating file.

Not sure what to do at this point, but it’s progress.

Update: I looked in /Applications/XAMPP/xamppfiles/var/mysql and noticed a .err file (should start with your local computer name, like johns-macbook-pro.local.err). It indicated that my permissions were screwed up: “The error means mysqld does not have the access rights to the directory. File name ./ibdata1”

Setting /Applications/xampp/xamppfiles/var/mysql/ and all its contents to be readable and writable for everyone did the trick. Probably the best solution is to chown -R mysqld /Applications/xampp/xamppfiles/var/mysql/.


I did something like this:

cd /Applications/XAMPP/xamppfiles/bin
ls -la 

I have this file:


We can symlink it:

rm mysql.server 
ln -s /Applications/XAMPP/xamppfiles/share/mysql/mysql.server mysql.server

… and I started MySQL from XAMPP's control panel.

  • Reading this is an answer to the question doesn't really make sense. – rtf Oct 22 '12 at 17:16

I fixed this by doing the folowing steps.

  1. Install XAMPP normally
  2. Copy the folders of database from the older location to the folder Application/XAMPP/xamppfiles/var/mysql
  3. Right click on folder and select Show Information.
  4. Add the user ADMIN to the list of users allowed
  5. Give permission read-only

This fixed for me when I changed my HD and I needed install all over again.



Look for error files, for example: /Applications/XAMPP/xamppfiles/var/mysql/[YOUR_COMPUTER_NAME].err

An error I sometimes have is:

Warning: World-writable config file '/Applications/XAMPP/xamppfiles/etc/my.cnf' is ignored

Meaning MySQL will ignore the my.cnf file because any-one and their mother can change it (security issue)

Go to the my.cnf file, right click > Get Info, Under Sharing & Permissions change Everyone permissions to No Access.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.